Closed Bug 1115115 Opened 5 years ago Closed 5 years ago

[Homescreen][RTL] Scroll bar on Homescreen is not mirrored

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(feature-b2g:2.2+, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1119057
2.2 S6 (20feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- affected

People

(Reporter: jlee, Assigned: kaze)

References

Details

(Whiteboard: [systemsfe])

Attachments

(2 files)

Description:
When scrolling on Homescreen with Arabic selected (RTL), scroll bar is not mirrored.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141223010202
2) On Homescreen, scroll up and down
3) Notice scroll bar location
  
Actual:
Scroll bar is seen on right side of Homescreen when scrolling with Arabic/RTL enabled.
  
Expected: 
Scroll bar is seen mirrored/on left side of Homescreen when scrolling with Arabic/RTL enabled.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20141223010202
Gaia: c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko: 0532f2509f3f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
  
Repro frequency: 4/4, 100%
See attached: screenshot (homescreenscroll.PNG), logcat (homescreenscroll_logcat.txt)
Attached image homescreenscroll
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(dharris)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(dharris)
[triage] We tried settings, email and a few other areas the scroll bar are correctly aligned and think we should be consistent especially since this is the homescreen
blocking-b2g: --- → 2.2+
Priority: -- → P1
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
blocking-b2g: 2.2+ → ---
feature-b2g: --- → 2.2+
Assignee: nobody → fabien
Status: NEW → ASSIGNED
Whiteboard: [systemsfe]
kaze, will this be fixed by bug 1119057?
Flags: needinfo?(fabien)
Yes, this is a dupe. Closing.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(fabien)
Resolution: --- → DUPLICATE
Duplicate of bug: 1119057
Target Milestone: --- → 2.2 S6 (20feb)
You need to log in before you can comment on or make changes to this bug.