[Woodduck][Start your phone tour]FTU crashed on the fourth screen.

RESOLVED DUPLICATE of bug 1115241

Status

P2
normal
RESOLVED DUPLICATE of bug 1115241
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.0M?, b2g-v2.0 unaffected, b2g-v2.0M affected, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created an attachment (id=1084299)
 verify video
 
 REPRODUCING PROCEDURES:
  
 1.Settings --> Developer --> Launch First Time Use
  
 2.Click "Next" until the fourth screen of "Start your phone tour",which is 
 
 "Drag from the left edge of your screen to return recently used apps".
 
 Waiting for several minutes in this screen, you will see "FTU justcrashed"
 
 NOTES:
 
 The issue appears on the 20141222054813-user version from Mozilla origin, but on 
 
 the 20141222054813-eng version it will not produce. 
 
 The message below grabbed by adb logcat :
 
 E/        (  159): GetPrevFBAcquireFd: FB acquire fence is invalid!
 E/        (  159): GetPrevFBAcquireFd: FB acquire fence is invalid!
 E/        (  159): GetPrevFBAcquireFd: FB acquire fence is invalid!
 E/        (  159): GetPrevFBAcquireFd: FB acquire fence is invalid!
 E/        (  159): GetPrevFBAcquireFd: FB acquire fence is invalid!
 E/        (  159): GetPrevFBAcquireFd: FB acquire fence is invalid!
 E/        (  159): GetPrevFBAcquireFd: FB acquire fence is invalid!
 E/        (  159): GetPrevFBAcquireFd: FB acquire fence is invalid!
 E/        (  159): GetPrevFBAcquireFd: FB acquire fence is invalid!
 E/        (  159): GetPrevFBAcquireFd: FB acquire fence is invalid!
 
 see the video for detail.
 
 Thanks!
 
 EXPECTED BEHAVIOUR:
  
 No crash should happen.
(Reporter)

Comment 1

4 years ago
Created attachment 8541062 [details]
verify video
(Reporter)

Comment 2

4 years ago
Created attachment 8541076 [details]
error picture

Comment 3

4 years ago
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Flags: needinfo?(fan.luo)

Updated

4 years ago
Blocks: 1054172, 1107999
blocking-b2g: --- → 2.0M?
This bug is exactly the same with bug 1115241.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1115241
Hi Josh,

   I can repro this bug on Woodduck 2.0(Rate:4/6), but can't repro on Flame v2.0&2.1&2.2 user build and generic build(Rate:0/4).
   Because today's woodduck user build has some problem which can't enter the fourth screen of "Start your phone tour",so I use the build(20141226050313-eng.zip) to test.

Flame 2.0 user build:
Gaia-Rev        01c32dcdc08b3c8fc8b3082870439fa2c1089f4f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/b41c344ed82d
Build-ID        20141225000210
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.032532
FW-Date         Thu Dec 25 03:25:43 EST 2014
Bootloader      L1TC00011880

Flame 2.1 user build:
Gaia-Rev        17c7ad2e4919a994f0844239b483116090412dee
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/39dfb662c82a
Build-ID        20141225001203
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.035330
FW-Date         Thu Dec 25 03:53:41 EST 2014
Bootloader      L1TC00011880

Flame 2.2 user build:
Gaia-Rev        6f2b5a28da17cb75a1802958a2c1dda225898bb8
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/986ef444a8bb
Build-ID        20141225160202
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.191509
FW-Date         Thu Dec 25 19:15:20 EST 2014
Bootloader      L1TC00011880

Woodduck 2.0 build:
Gaia-Rev        add38992bbfb2bafca52ac1ce7f6231ac702675f
Gecko-Rev       8d951d9c4988e218ec08c6118a35c7faeb70af49
Build-ID        20141225143517
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1419478053
FW-Date         Thu Dec 25 11:27:57 CST 2014
status-b2g-v2.0: --- → unaffected
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → unaffected
Flags: needinfo?(fan.luo)
Created attachment 8541556 [details]
logcat_woodduck_0842.txt
Created attachment 8541558 [details]
woodduck_0842.MP4

Add woodduck crash video.

Title: B2G 32.0 Crash Report [@ pthread_kill ]
Crash report: https://crash-stats.mozilla.com/report/index/96e3dc83-b6a1-4560-b9fc-36df02141226
You need to log in before you can comment on or make changes to this bug.