[FFOS2.0][Woodduck][Emergency call]Can't dial the emergency call stored in the sim(ril.ecclist).

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
P1
normal
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [POVB])

Attachments

(1 attachment)

3.91 MB, application/x-rar
Details
(Reporter)

Description

3 years ago
DEFECT DESCRIPTION:
 Can't dail the emergency call number stored in the sim.
 
  REPRODUCING PROCEDURES:
 1.Insert a sim card that stored emergency numbers(the ril.ecclist) into the phone.
 2.Dial the numbers, the callscreen looks like a normal call but not a emergency call.
 
 
 Except:
   The call should be a emergency call.

Comment 1

3 years ago
Hi Shawn,
CIs this POVB? Thanks!
Blocks: 1054172
Flags: needinfo?(sku)
Summary: [FFOS2.0][Woodduck][Emergency call]Can't dail the emerfency call stored in the sim(ril.ecclist). → [FFOS2.0][Woodduck][Emergency call]Can't dial the emergency call stored in the sim(ril.ecclist).

Comment 2

3 years ago
ril.ecclist/ro.ril.ecclist was handled by rild. Please make sure rild has this done properly.
Flags: needinfo?(sku) → needinfo?(wudduc)

Comment 3

3 years ago
Created attachment 8541408 [details]
mtklog.rar

dear mozilla:
  We put 911 as a emengency number in our simulate sim card.Then we dial the number 999.In our log ,i find this:

12-24 08:31:11.112   162   162 I Gecko   : TelephonyService: Dialing emergency 999
12-24 08:31:11.115   162   620 I Gecko   : RIL Worker: [0] Received chrome message {"number":"999","isDialEmergency":true,"rilMessageClientId":0,"rilMessageToken":14,"rilMessageType":"dial"}
12-24 08:31:11.118   162   162 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"number":"999","isDialEmergency":true,"rilMessageClientId":0,"rilMessageToken":14,"rilMessageType":"dial","success":false,"errorMsg":"BadNumberError"}


and the callscreen looks like a normal call but not a emegency call.

Comment 4

3 years ago
Dear mozilla:
  May I ask how is it going on?

Comment 5

3 years ago
Hi Jason,
Can yo help to check rild per comment 2 from Shawn? Thanks!
Flags: needinfo?(chien-hao.li)

Updated

3 years ago
Blocks: 1080337

Updated

3 years ago
Priority: P2 → P1

Comment 6

3 years ago
Hi Wenquan, Please check it. Thanks.
Flags: needinfo?(wudduc)
Flags: needinfo?(wenquan.zhong)
Flags: needinfo?(chien-hao.li)

Comment 7

3 years ago
Hi, Shawn, I can't see the dial request sent to rild, and from the log:
"errorMsg":"BadNumberError"}
It seems that the number is considered as invalid, where will check the number?

Updated

3 years ago
Flags: needinfo?(wenquan.zhong) → needinfo?(sku)

Comment 8

3 years ago
Hi woodduck:
 This was caused by 999 is not in eccList, and device get "searching" state while requesting dial 999.
Since 999 is not in ril.eccList, and device not in full service.
This call can *not* be made.


12-24 08:31:11.112   162   162 I Gecko   : TelephonyService: Dialing emergency 999
12-24 08:31:11.115   162   620 I Gecko   : RIL Worker: [0] Received chrome message {"number":"999","isDialEmergency":true,"rilMessageClientId":0,"rilMessageToken":14,"rilMessageType":"dial"}
12-24 08:31:11.118   162   162 I Gecko   : -*- RadioInterface[0]: Received message from worker: {"number":"999","isDialEmergency":true,"rilMessageClientId":0,"rilMessageToken":14,"rilMessageType":"dial","success":false,"errorMsg":"BadNumberError"}


// No/limited service
12-24 08:33:04.273   865   865 I Gecko   : -*- RILContentHelper: Received message 'RIL:VoiceInfoChanged': {"clientId":0,"data":{"connected":false,"emergencyCallsOnly":true,"roaming":false,"network":null,"cell":null,"type":null,"signalStrength":null,"relSignalStrength":null,"state":"searching"}}

// Get service
12-24 08:33:05.557   538   557 D use-Rlog/RLOG-AT: +CREG: 5, "0001", "00000001", 0, 0
12-24 08:33:05.652   865   865 I Gecko   : -*- RILContentHelper: Received message 'RIL:VoiceInfoChanged': {"clientId":0,"data":{"connected":true,"emergencyCallsOnly":false,"roaming":true,"network":{"longName":"00101","shortName":"00101","mcc":"001","mnc":"01"},"cell":{"gsmLocationAreaCode":1,"gsmCellId":1},"type":"gprs","signalStrength":-63,"relSignalStrength":100,"state":"registered"}}
Flags: needinfo?(sku) → needinfo?(wudduc)

Comment 9

3 years ago
Hi, Xingming, please reproduce this issue and catch the log after the phone camp on network, thanks!
Flags: needinfo?(wudduc) → needinfo?(xingming.yin.hz)

Comment 10

3 years ago
Update: Partner has solved the problem. Close this issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(xingming.yin.hz)
Resolution: --- → WORKSFORME
Whiteboard: [POVB]
You need to log in before you can comment on or make changes to this bug.