Closed Bug 1115317 Opened 5 years ago Closed 5 years ago

[Flame][Contacts]Can't see how many contacts were added after exported contacts via bluetooth.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

VERIFIED FIXED
2.2 S3 (9jan)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified

People

(Reporter: lulu.tian, Assigned: fcampo)

Details

(Keywords: regression)

Attachments

(7 files)

Attached file logcat_1425.txt
[1.Description]:
[Flame v2.2][Contacts]
When received contacts via Bluetooth, we can't see the whole notification bar of how many contacts were added.
Found time:14:25 
See attachment:1425.MP4 and logcat_1425.txt

[2.Testing Steps]: 
PREREQUISITES: Bluetooth is On and paired to another device. 
1. Export 4 contacts to test device via Bluetooth from a device paired to test device.
2. Tap on the Bluetooth notification.
3. Tap Transfer.
4. Tap the Notification when the transfer finishes.
**The sender's device will display 4/4 contacts exported, but test device displays nothing.

[3.Expected Result]: 
4. The Contacts app loads and adds the imported contacts to the contact list, then displays a notification with details of how many contacts were added.

[4.Actual Result]: 
4. The Contacts app loads and adds the imported contacts to the contact list, but we just see the 1/4 part of the notification. So we can't know how many contacts were added.

[5.Reproduction build]: 
Gaia-Rev        c2da2bafd4e809317e2ca70c9bf5c11136a32818
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/0532f2509f3f
Build-ID        20141223010202
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: 10250
Attached video video
Attached image 2014-12-25-17-38-08.png
Hi sue, Could you try again with newer build or previous one? I cannot reproduce this, thank you.
Flags: needinfo?(lulu.tian)
Attached file logcat_1002.txt
Hi Eric,
I can repro this issue on lasted build of Flame 2.2, I have uploaded the logcat and the picture.
See attachment: logcat_1002.txt and 2014-12-25-10-02-43.png
Found time:10:02

Flame 2.2 build:
Gaia-Rev        ab41c35eed35404b632a4841714b81b56364ba32
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2acb12da9813
Build-ID        20141225010202
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.043916
FW-Date         Thu Dec 25 04:39:27 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(lulu.tian) → needinfo?(echang)
Attached image 2014-12-25-10-02-43.png
Hi Francisco, I cannot reproduce this, but there is an error in the log, could you help to check this, thanks.

12-25 10:02:41.945 W/Communications( 1567): Content JS WARN: L10nError: "Imported 4 contacts" not found in en-US in app://communications.gaiamobile.org/contacts/index.html?open 

12-25 10:02:41.945 W/Communications( 1567):     at reportMissingEntity (app://communications.gaiamobile.org/contacts/gaia_build_defer_index.js:175:1879)
Flags: needinfo?(echang) → needinfo?(francisco)
I cannot reproduce either, pinging Jose, since he did a string change recently that could be related.
Flags: needinfo?(francisco) → needinfo?(jmcf)
The utils.status component is expecting a l10N id 

https://github.com/mozilla-b2g/gaia/blob/master/shared/js/contacts/import/utilities/status.js#L45

(since the L10N latest code refactoring) and we are passing directly the localized string. 

https://github.com/mozilla-b2g/gaia/blob/master/shared/js/contacts/import/utilities/import_from_vcard.js#L134

That's the cause of the problem. We need to check in all parts of the code as presumably we have the same problem in other importations. 

Taking it an target next sprint
Flags: needinfo?(jmcf)
Assignee: nobody → jmcf
Target Milestone: --- → 2.2 S3 (9jan)
blocking-b2g: --- → 2.2?
Johan can you please also check if it happens on 2.1?

triage: blocker
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(jlorenzo)
This issue doesn't repro on 2.1, the notification "4 contacts imported" appears correctly:
Gaia-Rev        b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/99cea2c818f6
Build-ID        20150106001308
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  65
FW-Date         Mon Dec 15 18:51:29 CST 2014
Bootloader      L1TC000118D0
Flags: needinfo?(jlorenzo)
Assignee: jmcf → fernando.campo
Comment on attachment 8546562 [details] [review]
Link to PR  - https://github.com/mozilla-b2g/gaia/pull/27278

please check the comments on GH and land once everything is green

thanks Fernando
Attachment #8546562 - Flags: review?(jmcf) → review+
Comment on attachment 8546562 [details] [review]
Link to PR  - https://github.com/mozilla-b2g/gaia/pull/27278

please check the comments on GH and land once everything is green

thanks Fernando
green and landed - https://github.com/mozilla-b2g/gaia/commit/2c7d14040149e1f9b1bb3972ff150be0472fa6b6
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Attached video verify_video.MP4
This issue has been verified successfully on Flame 2.2
See attachment:verify_video.MP4
Rate:0/5

Flame 2.2 build:
Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bb8d6034f5f2
Build-ID        20150111010223
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150111.043244
FW-Date         Sun Jan 11 04:32:55 EST 2015
Bootloader      L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.