Closed Bug 1115345 Opened 10 years ago Closed 9 years ago

[e10s] "uitour" entry point does not work in e10s

Categories

(Firefox :: Tours, defect)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
Tracking Status
e10s m7+ ---

People

(Reporter: FlorinMezei, Unassigned)

References

Details

Reproducible with: Firefox 37 Nightly latest - BuildID: 20141223030207

Reproducible on: Windows 7 x64, Mac OS X 10.9.5, Ubuntu 14.04 x64

Steps to reproduce:
1. Open Firefox and go to Help -> Nightly Tour.
2. Go to Tools -> Set Up Sync.

Expected results:
User is taken to about:accounts?entrypoint=uitour.

Actual results:
User is taken to about:accounts?entrypoint=menubar (also if the tour is started and "Sign in to Sync" is clicked at the first tour page, then "menupanel" will be the entry point displayed, when "uitour" is expected). According to bug 1053939, when on the UI Tour tab, going to the sync landing page from anywhere should use the "uitour" entry point. 

Disabling e10s works as expected and does display the "uitour" entry point.
Version: 35 Branch → Trunk
Flags: needinfo?(adw)
Not directly related to sync migration, but I think we should try and block it so we can get good server-side stats on the migration process.
Blocks: migratesync
Flags: qe-verify+
Flags: firefox-backlog+
Best I can tell, this is blocked by bug 1089000 - the functionality we use in UITour.jsm is explicitly disabled with e10s with that bug mentioned in the comments.

http://dxr.mozilla.org/mozilla-central/source/browser/modules/UITour.jsm#653
Depends on: 1089000
I agree with Mark, Sync and FxA use UITour.originTabs to determine whether a page is a UITour page and should therefore trigger the UITour entry point:

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-syncui.js?rev=1f86aebdcc2e#307

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-fxaccounts.js?rev=3c7defb79660#344

But UITour.originTabs doesn't include the content windows of e10s browser windows:

http://hg.mozilla.org/mozilla-central/file/f2b28a37a4c0/browser/modules/UITour.jsm#l653
Flags: needinfo?(adw)
bug 1089000 blocks e10s m7.
Moving open UITour bugs to Firefox::Tours. Filter on firefox-tours-20150121.
Component: Sync → Tours
This works as expected now.  Looks like it was fixed by bug 1110602.  https://hg.mozilla.org/integration/fx-team/diff/fad9208f38f1/browser/base/content/browser-fxaccounts.js
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Removing qe-verify flag since Drew confirmed this works now.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.