DevEdition theme - Inconsistent borders on toolbars

VERIFIED FIXED in Firefox 38

Status

()

Firefox
Theme
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: ntim, Assigned: bgrins)

Tracking

unspecified
Firefox 38
All
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [devedition-polish][testday-20150901])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
See attachment 8536605 [details], the navbar doesn't borders on the sides, while the bookmarks toolbar does have some. This makes the light theme look unpolished.
(Reporter)

Updated

3 years ago
Whiteboard: [devedition-polish]
(Assignee)

Comment 1

3 years ago
It appears in the screenshot that you have the patch from Bug 1093820 applied.  Do you see this problem even without that?
(Reporter)

Comment 2

3 years ago
(In reply to Brian Grinstead [:bgrins] from comment #1)
> It appears in the screenshot that you have the patch from Bug 1093820
> applied.  Do you see this problem even without that?

Yes. I see that without the patch.
(Assignee)

Comment 3

3 years ago
Created attachment 8549144 [details] [diff] [review]
toolbar-border-windows.patch

Tim, does it look better with this patch applied?
Attachment #8549144 - Flags: feedback?(ntim007)
(Reporter)

Comment 4

3 years ago
Comment on attachment 8549144 [details] [diff] [review]
toolbar-border-windows.patch

Review of attachment 8549144 [details] [diff] [review]:
-----------------------------------------------------------------

Fixes the issue for me.
Attachment #8549144 - Flags: feedback?(ntim007) → feedback+
(Assignee)

Comment 5

3 years ago
Comment on attachment 8549144 [details] [diff] [review]
toolbar-border-windows.patch

Checked on OSX and Ubuntu and this Windows fix doesn't seem to cause any changes, so requesting review
Attachment #8549144 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8549144 [details] [diff] [review]
toolbar-border-windows.patch

Review of attachment 8549144 [details] [diff] [review]:
-----------------------------------------------------------------

This was annoying me the other day on win8. Thanks!
Attachment #8549144 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Comment 7

3 years ago
Created attachment 8549190 [details] [diff] [review]
toolbar-border-windows-r=Gijs.patch

Adds commit message
Assignee: nobody → bgrinstead
Attachment #8549144 - Attachment is obsolete: true
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Attachment #8549190 - Flags: review+
(Assignee)

Comment 8

3 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=327be8db5e75
Keywords: checkin-needed
Hi, seems this doesn't apply cleanly:

patching file browser/themes/shared/devedition.inc.css
Hunk #2 FAILED at 221
1 out of 2 hunks FAILED -- saving rejects to file browser/themes/shared/devedition.inc.css.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working dir
errors during apply, please fix and refresh toolbar-border-windows.patch

could you take a look, thanks!
Flags: needinfo?(bgrinstead)
Keywords: checkin-needed
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1097598
(Assignee)

Comment 11

3 years ago
Rebased and pushed to fx-team:

https://hg.mozilla.org/integration/fx-team/rev/2cc184d6dc0f
Flags: needinfo?(bgrinstead)
Whiteboard: [devedition-polish] → [fixed-in-fx-team][devedition-polish]
https://hg.mozilla.org/mozilla-central/rev/2cc184d6dc0f
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team][devedition-polish] → [devedition-polish]
Target Milestone: --- → Firefox 38

Comment 13

2 years ago
This has been verified fixed for a QA test day.
Status: RESOLVED → VERIFIED
Whiteboard: [devedition-polish] → [devedition-polish][testday-20150901]
You need to log in before you can comment on or make changes to this bug.