Closed Bug 1115396 Opened 5 years ago Closed 4 years ago

[firefox os 2.2] 3 rocket icons that do nothing, and show up as running nothing when opened

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: Jamie_, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141215134203

Steps to reproduce:

1.) Install 2.2
2.) open 2.2
3.) scroll down to three "rocket icons"
4.) select
ONLY HAPPENS WHEN FIRST INSTALLS ON FIRST RUN


Actual results:

when you open them it opens a black screen with a X in the corner to close it. Also shows as nothing running when opening task manager


Expected results:

Unknown???? They do nothing that i know of or if they should be there???
In js/init.json, I can see that:
  [{"id":289,"role":"collection"},{"id":207,"role":"collection"},{"id":142,"role":"collection"}],

Homescreen developers, is that expected ??

You can easily reproduce that by building a profile like this and running b2g-desktop:
$ NOFTU=1 make
$ .../b2g-bin -profile profile/
Component: Simulator → Gaia::Homescreen
Alexandre can you see what you can do with this, its still validly going on and I have no clue what to do with this.
Flags: needinfo?(poirot.alex)
Something is wrong with rocketbar, not the simulator itself. It is really up to homescreen dev to look into this.
Why rocketbars behaves like this on desktop.

Kevin, any guess, or who could look into this?
Flags: needinfo?(poirot.alex) → needinfo?(kgrandon)
These are smart collection icons, and not the rocketbar. The problem is that we currently populate their data from FTU, and not on home screen first launch. Since we never launch the FTU in the simulator, this won't work as is. We can fix this, but I imagine it's a bit of work, and we'd need to move the collection population from FTU to the system app.
Flags: needinfo?(kgrandon)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.