Window controls disappear or don't work: minimize/maximize/close

RESOLVED DUPLICATE of bug 1089312

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1089312
3 years ago
3 years ago

People

(Reporter: Ray Satiro, Unassigned)

Tracking

37 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8541384 [details]
Faux Buttons.gif

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20141219030202

Steps to reproduce:

No way to reproduce


Actual results:

It's happened rarely that for a window the minimize/maximize/close window controls will disappear and in their place is a black square. If I hover over the black square different nonfunctional window controls will appear, similar to the buttons one might see with window scheme Basic. I have attached an animated gif showing what happens when I hover over. Other windows and new windows appear to function normally.

I have Aero enabled and the window control buttons I normally see in Nightly windows are the correct Aero ones.

Graphics
--------

Adapter Description: Intel(R) HD Graphics 3000
Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter RAM: Unknown
ClearType Parameters: D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 ]
Device ID: 0x0122
DirectWrite Enabled: false (6.2.9200.16571)
GPU #2 Active: false
GPU Accelerated Windows: 0/2 Basic (OMTC)
Subsys ID: 00000000
Vendor ID: 0x8086
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D11 vs_4_1 ps_4_1)
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0



Expected results:

The aero window controls should function properly and not disappear.

Comment 1

3 years ago
Do you see any driver date in about:support?

Updated

3 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
(Reporter)

Comment 2

3 years ago
(In reply to Loic from comment #1)
> Do you see any driver date in about:support?

No but it's 1/29/2014, version 9.17.10.3347.

Comment 3

3 years ago
Do you use a special theme for Firefox?

Could you try to update your drivers to the latest version (15.28.22.64.3517)?
(Reporter)

Comment 4

3 years ago
(In reply to Loic from comment #3)
> Do you use a special theme for Firefox?
> 
> Could you try to update your drivers to the latest version
> (15.28.22.64.3517)?

I'm using "Google Chrome 4 Firefox" right now:
https://addons.mozilla.org/en-us/firefox/addon/google-chrome-4-firefox/

I'll probably leave the drivers as is. I don't have this problem with any other program.

Comment 5

3 years ago
Remove/change the theme, it should be fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089312
(Reporter)

Comment 6

3 years ago
(In reply to Loic from comment #5)
> Remove/change the theme, it should be fixed.
> 
> *** This bug has been marked as a duplicate of bug 1089312 ***

I don't know if that's the same issue. Mine rarely happens and it's not reproducible.
You need to log in before you can comment on or make changes to this bug.