[Flame][Music]The audio will not play while we tap shuffle all button to play in playlist page.



Firefox OS
3 years ago
18 days ago


(Reporter: Paladin, Unassigned)


Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 unaffected)



(4 attachments)



3 years ago
Created attachment 8541456 [details]

[Flame][v2.1][Music] The audio will not play while we tap shuffle all button to play in playlist page.
Attachment: logcat_flame_1548.txt and no_play.3gp
Occurrence time: 15:48

[2.Testing Steps]: 
Set up: There is only one audio in device.

1. Open Music.
2. Tap playlist button on the bottom.
3. Tap Shuffle all  button in playlist page.

[3.Expected Result]: 
The audio should play normally.

[4.Actual Result]: 
3. The audio will not play.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        17c7ad2e4919a994f0844239b483116090412dee
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/39dfb662c82a
Build-ID        20141224001203
Version         34.0

Flame 2.2 Build:
Gaia-Rev        cb1dad4881533bff9f06d47e34983c7b10c04a8c
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/b17e7747d3fb
Build-ID        20141224010204
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free Test

Note:In step 3, we can into play page, but even if tap play button ,the audio still can't play.

Comment 1

3 years ago
Created attachment 8541457 [details]

Comment 2

3 years ago
Hi Dominic, please help to check with this, thanks.
v2.2 doesn't have this issue.
Flags: needinfo?(dkuo)

Comment 3

3 years ago
Mike, do you have the test file? it looks like an unplayable audio file so it will be nice to debug with it, thanks.
Flags: needinfo?(dkuo) → needinfo?(mlien)

Comment 4

3 years ago
Created attachment 8544444 [details]
Demonlord - Quo Vadis.mp3

please refer to this audio file
Flags: needinfo?(mlien)

Comment 5

3 years ago
Created attachment 8564951 [details]

I can reproduce this issue on latest Flame 2.1 
Reproducing rate: 5/5
See New Log: logcat_flame_1840.txt

Device Info:
Build ID               20150215001204
Gaia Revision          e8eba437af02820f74d122aec83b6001df6f89e3
Gaia Date              2015-02-13 05:26:11
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/9d04f9149ca4
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.040742
Firmware Date          Sun Feb 15 04:07:53 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(mlien)

Comment 6

3 years ago
Wait for developer's reply
Flags: needinfo?(mlien)
Going to check and see if this is a corrupt file. If so, this is probably fixed by Bug 1149930.
Flags: needinfo?(jdarcangelo)
Clearing old NI? requests. Please re-flag me if necessary. Thanks
Flags: needinfo?(jdarcangelo)

Comment 9

18 days ago
Firefox OS is not being worked on
Last Resolved: 18 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.