Scrolling of frame with two-finger swipe can get "stuck" in E10S mode

RESOLVED DUPLICATE of bug 863514

Status

()

Core
IPC
RESOLVED DUPLICATE of bug 863514
4 years ago
2 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox37 ?)

Details

(Whiteboard: [Description in comment #2])

> Try scrolling this page horizontally

How exactly did you scroll?  By grabbing the scrollbar (with a mouse or trackpad)?  Using a two-finger horizontal swipe (with a trackpad)?  Do the problems happen with one method and not the other?

What, exactly, is the problem?  Is it jank?

> I'm using E10s, I didn't try non-E10s

Please try non-e10s mode and see if it makes a difference.

I assume you tested with a recent m-c nightly.  If not, please let us know.
Testing with a two-finger horizontal swipe with today's m-c nightly on OS X 10.7.5, I do see *a* problem (a pretty serious one):

Both horizontal and vertical scrolling (with a two-finger swipe) can get "stuck", so that it (temporarily) doesn't work at all.  When this happens, you can scroll left or right only a small fraction of an inch (enough to make the horizontal scroll bar appear).  Vertical scrolling (with the two-finger swipe) appears to have no effect at all -- only the page scrolls (not the frame).

Note that the top line of the chart ("Route Number") isn't supposed to scroll at all -- only the second line and below.

This bug doesn't happen in non-e10s mode.
Summary: Scrolling horizontally works poorly on OS X 10.9 on the touch pad of MBP → [e10s] Scrolling of frame with two-finger swipe can get "stuck" temporarily
> This bug doesn't happen in non-e10s mode.

It also doesn't happen (even in e10s mode) if you grab the scrollbar to scroll.
This bug also happens on Windows (Windows XP, testing with today's m-c nightly).  There the problem is permanent (as best I can tell) -- not "temporary".
Component: Widget: Cocoa → IPC
OS: Mac OS X → All
Hardware: x86 → All
Summary: [e10s] Scrolling of frame with two-finger swipe can get "stuck" temporarily → [e10s] Scrolling of frame with two-finger swipe can get "stuck"
status-firefox37: --- → ?
Here's the regression range for this bug on OS X:

firefox-2014-02-21-03-02-02-mozilla-central
firefox-2014-02-22-03-02-04-mozilla-central

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7010ab83a06e&tochange=84c9885475e7

This isn't the regression range for Windows.  And now I see that the problem happens on Windows even in non-e10s mode -- so the Windows problem must be a different bug.
OS: All → Mac OS X
Duplicate of this bug: 1114666
Bug 1114666 has a simpler testcase (though just for horizontal scrolling).
Whiteboard: [Description in comment #2]
Summary: [e10s] Scrolling of frame with two-finger swipe can get "stuck" → Scrolling of frame with two-finger swipe can get "stuck"
This really is an E10S bug, Brad.  Shouldn't we use "[e10s]" for them?
Flags: needinfo?(blassey.bugs)
Summary: Scrolling of frame with two-finger swipe can get "stuck" → Scrolling of frame with two-finger swipe can get "stuck" in E10S mode
Here's that patch that triggered this bug:

http://hg.mozilla.org/mozilla-central/rev/52c1eacc3f77

 Bug 863514 - Don't disable gestures in e10s even if they're partially broken r=billm
author	Tim Taubert <ttaubert@mozilla.com>
	Sun Feb 16 19:32:32 2014 +0100 (at Sun Feb 16 19:32:32 2014 +0100)

I frankly have no idea why.  Tim, do you have any ideas?
Flags: needinfo?(ttaubert)
(I am part of the e10s "them")

We read your previous comment as saying that it *wasn't* e10s related.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(blassey.bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 863514
I still don't understand.

This bug clearly isn't a dup of bug 863514.

Is the problem that *no* gestures work as they should in e10s mode?  Or *some* of them?

Then why, in the case of this bug, does the two-finger swipe gesture work as expected (in e10s mode) when e10s-specific support is turned off?
Flags: needinfo?(blassey.bugs)
(In reply to Steven Michaud from comment #11)
> I still don't understand.
> 
> This bug clearly isn't a dup of bug 863514.
Why not?
> 
> Is the problem that *no* gestures work as they should in e10s mode?  Or
> *some* of them?
We can't (or probably more specifically don't) properly interrogate the content to determine what the appropriate action to take is. This most commonly manifests as either nothing happening when the user attempts to scroll horizontally or the back gesture happning
 
> Then why, in the case of this bug, does the two-finger swipe gesture work as
> expected (in e10s mode) when e10s-specific support is turned off?
I don't understand that question
Flags: needinfo?(blassey.bugs)
(In reply to comment #12)

Brad, you've misunderstood this bug.

This bug happens only in e10s mode.  It's triggered by a patch (http://hg.mozilla.org/mozilla-central/rev/52c1eacc3f77) that appears to turn *on* e10s-specific gesture support.

My question is why does this bug's gesture (the two-finger horizontal swipe used to scroll a frame) work, in e10s mode, only when e10s-specific gesture support is turned *off*?
(In reply to Steven Michaud from comment #9)
> I frankly have no idea why.  Tim, do you have any ideas?

Sorry, I have no idea why turning it on breaks it at the same time. It worked for me back then but I don't know a lot about our gesture implementation.
Flags: needinfo?(ttaubert)

Updated

2 years ago
Duplicate of this bug: 1115716
You need to log in before you can comment on or make changes to this bug.