Hiding a toolbar in one window hides it in all other windows

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: sole, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

If I select View -> Toolbars -> Bookmarks toolbar the action affects all windows, hiding or showing the toolbar in all of them, which is totally unexpected.

I expect the action to only have effect over the currently focused window.
(In reply to Soledad Penades [:sole] [:spenades] from comment #0)
> If I select View -> Toolbars -> Bookmarks toolbar the action affects all
> windows, hiding or showing the toolbar in all of them, which is totally
> unexpected.
> 
> I expect the action to only have effect over the currently focused window.

All toolbar customization (buttons, toolbar visibility, titlebar state, devedition theme, ...) are global. I don't think we should change that for just toolbar visibility.

Why do you expect what you expect, and how could we make what happens more obvious?
Flags: needinfo?(sole)
(Reporter)

Comment 2

4 years ago
Hey

For example I want to open a new window for making a demo and I don't want to show a lot of browser chrome when screen capping, so I hide the toolbar. But then it hides it everywhere else! and I have to reshow it later on when I'm done with this "temporary" window.

Or for example I might want to pop a tab out to a new window to watch a video. I will hide the toolbars on that one so I get more screen space, but I do not want to hide the toolbars on the main window because I am using them!

I think the reason why I feel this behaviour is more consistent is because it feels like every browser window is a "document" and so I can change its settings separately. Then when I close it, it's gone, along with all the specific settings I created.

FWIW, Chrome shares this global behaviour too.
Flags: needinfo?(sole)
(In reply to Soledad Penades [:sole] [:spenades] from comment #2)
> Hey
> 
> For example I want to open a new window for making a demo and I don't want
> to show a lot of browser chrome when screen capping, so I hide the toolbar.
> But then it hides it everywhere else! and I have to reshow it later on when
> I'm done with this "temporary" window.

It sounds like you want to do a screencap of just the page? GCLI and responsive mode let you do this, I think (but then, you'd know better than me).

> Or for example I might want to pop a tab out to a new window to watch a
> video. I will hide the toolbars on that one so I get more screen space, but
> I do not want to hide the toolbars on the main window because I am using
> them!

This sounds like you want to fullscreen the video/page...


I guess I understand why you want the behaviour you do, but I'm not convinced we can change this wholesale without the rest of the world perceiving it as a "regression".

An alternative would be to be intelligent about "temporary windows", for which we currently don't really have infrastructure. It'd be interesting to do something there, but very hard to get right algorithmically for windows you create (webpages can specify toolbar=no,menubar=no,chrome=no for popups created with window.open, of course). I'm not sure if that would be hard to do, and if it would be intuitive enough. In your usecase, for instance, it sounds like these windows will have only 1 tab, in which case that could be a distinguishing factor, but maybe they will not, and/or there are probably (no, I should say 'certainly' - we have data!) a lot of people that don't use tabs a lot, and the behaviour would be confusing there (a la "why does changing the toolbar state in a window with one tab change it only for that window, but changing it in a window with multiple tabs change it everywhere?" - the single-tab case would probably be regarded as a bug by those users).

All in all I am not sure what, if anything, we can do here. Philipp, do you have more intelligent suggestions than me, maybe? :-)
Flags: needinfo?(philipp)
I agree with everything you've mentioned Gijs and add that this would also create the question of what a newly created window would look like after changing something. Plus, the behavior Firefox uses is near-universal in the desktop software world.

I can't think of anything we could do here that wouldn't be better off living in an add-on.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(philipp)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.