Closed Bug 1115538 Opened 7 years ago Closed 7 years ago

Error running mach with hg revision 221200

Categories

(Firefox Build System :: General, defect)

x86_64
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1116194

People

(Reporter: glennrp+bmo, Unassigned)

References

Details

"./mach build" produces an error.  Affected: m-c revision 221200; not affected 221197.  I'm running on Ubuntu 14.04. Here's the mach output:

$ ./mach build

Error running mach:

    ['build']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

AttributeError: 'module' object has no attribute 'linux_sysinfo'

  File "/home/glennrp/M/FF/d/python/mozbuild/mozbuild/mach_commands.py", line 290, in build
    monitor.init(warnings_path)
  File "/home/glennrp/M/FF/d/python/mozbuild/mozbuild/controller/building.py", line 164, in init
    self.resources = SystemResourceMonitor(poll_interval=1.0)
  File "/home/glennrp/M/FF/d/testing/mozbase/mozsystemmonitor/mozsystemmonitor/resourcemonitor.py", line 188, in __init__
    virt = psutil.virtual_memory()
  File "/home/glennrp/M/FF/d/python/psutil/psutil/__init__.py", line 1662, in virtual_memory
    ret = _psplatform.virtual_memory()
  File "/home/glennrp/M/FF/d/python/psutil/psutil/_pslinux.py", line 144, in virtual_memory
    total, free, buffers, shared, _, _ = cext.linux_sysinfo()
Probably due to landing bug #930808

For what it's worth, python on Ubuntu-14:04 is version 2.7.6
Depends on: 930808
It looks like the inconsistent build state isn't limited to OS X :/

`rm python/psutil/*.so` and try again.
Flags: needinfo?(glennrp+bmo)
(In reply to Gregory Szorc [:gps] from comment #2)

> `rm python/psutil/*.so` and try again.

That works for me on Ubuntu 14.04LTS.  Thanks.
Flags: needinfo?(glennrp+bmo)
FYI, don't give numeric revisions, they're useless: they only work for *your* clone, and tell nothing for anyone else.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 1115675
Duplicate of this bug: 1115968
Duplicate of this bug: 1116084
Might as well complete the chain. So many bugs filed for this issue...
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1116194
odd that searching for 'linux_sysinfo' in bugzilla didn't return any of these other bugs.
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.