If no mail accounts exist, disable Message Filters

VERIFIED DUPLICATE of bug 67219

Status

MailNews Core
Filters
--
major
VERIFIED DUPLICATE of bug 67219
16 years ago
10 years ago

People

(Reporter: David Brittain, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Having never tried to use filters before I tried to use them in a newly
installed version of 0.9.6. The Message Filter window appears, but clicking new
does nothing. In the 'Filters for' tab there are no entries present. This might
be related to bug 111149, but unlike the reporter in that bug I have not
imported any filters from NS4.x as I have never tried to use them in any version
of NS/mozilla before. It may be relevant that I have no mail accounts and only
use the Mozilla mail/news component for browsing news - I wanted to use the
filters to get rid of all the spam in the mozilla newsgroups.

Comment 1

16 years ago
what's more relevant is that this isn't implemented.

the only question is should the ui not allow you to try or somehow explain why you can't do this.

*** This bug has been marked as a duplicate of 16913 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: Can't create new filters → Can't create news filters

Comment 2

16 years ago
Reopen bug and change summary.

If the user has news accounts but no mail accounts, the "Edit: Message Filter" 
menu item should be disabled since the feature is not available.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Can't create news filters → If no mail accounts exist, disable Message Filters

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 67219 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.