Mouse movement disturbs combo box functionality (navigation & search bars)

VERIFIED DUPLICATE of bug 1043584

Status

()

Firefox
Address Bar
VERIFIED DUPLICATE of bug 1043584
3 years ago
3 years ago

People

(Reporter: Onur Safak, Unassigned)

Tracking

34 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
=== TO REPRODUCE ===

- begin typing in the nav bar
* autocomplete appears in the input area
* suggestions open as pull down
- move the mouse over suggestions
* a hovered suggestion item gets highlighted
- (optional) move the mouse out of the suggestion area

- hit ENTER
or
- hit DELETE



=== ACTUAL RESULTS ===

when you hit ENTER;
fx navigates to the last hovered suggestion item

when you hit DELETE;
last hovered suggestion item is removed



=== EXPECTED RESULTS ===

when you hit ENTER;
fx should search / navigate to the address seen in the input area

when you hit DELETE;
the text in the input area should be edited with normal delete functionality



=== NOTES ===

* Same thing goes with the search bar.
* This always happens when you have one hand on mouse while entering something in the nav bar, causing the mouse move and make you navigate to a irrevelant page or delete history items while trying to edit the nav bar

Comment 1

3 years ago
Fixed in FF36+.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043584
(Reporter)

Comment 2

3 years ago
This report includes the one stated (bug 1043584), but it also reports the DELETE key, which is still not fixed.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

3 years ago
This should be related, not duplicate. Don't know how to remove the duplicate status...

Comment 4

3 years ago
File a new bug, please.
You need to log in before you can comment on or make changes to this bug.