[Flame][Market Custom Framework]The"free" icon on main page of marketplace will not change to "Loading"after tap it.

RESOLVED WONTFIX

Status

Firefox OS
General
RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: Alissa(leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8541643 [details]
logcat.txt

[1.Description]:
[Flame][v2.1&2.2][Market Custom Framework]The"free" icon on main page of marketplace will not change to "Loading" after tapping it to install.
Occurence time:4:35PM
see attachments:logcat.txt,1226.3gp.
[2.Testing Steps]: 
1.Launch marketplace.
2.Tap Fee button.
3.Before install page appears,tap "free" agian.

[3.Expected Result]: 
2.The "free" icon should change to "loading".

[4.Actual Result]: 
2.It keeps "free".
3.Error alert pop up.

[5.Reproduction build]: 
Flame 2.2:
Gaia-Rev        ab41c35eed35404b632a4841714b81b56364ba32
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2acb12da9813
Build-ID        20141225010202
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2

Flame 2.1build:
Gaia-Rev        17c7ad2e4919a994f0844239b483116090412dee
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/39dfb662c82a
Build-ID        20141225001203
Version         34.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8541649 [details]
1226.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Component: Gaia → General
Product: Firefox OS → Marketplace
Version: unspecified → Avenir

Comment 2

3 years ago
The button doesn't change because the log says:

12-26 16:34:39.958 I/GeckoDump(  207): XXX FIXME : Got a mozContentEvent: webapps-install-denied

12-26 16:34:40.078 E/GeckoConsole( 9290): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1419286793073:4 in u/<: [installer] Install failed: DENIED

12-26 16:34:40.078 E/GeckoConsole( 9290): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1419286793073:4 in u/<: [buttons] App install deferred was rejected for  El juego del abecedario de Big Bird

12-26 16:34:40.078 E/GeckoConsole( 9290): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1419286793073:4 in u/<: [buttons] Unsuccessful install for El juego del abecedario de Big Bird

Then when the user clicks reinstall it says:

12-26 16:34:58.558 E/GeckoConsole(  207): [JavaScript Error: "Error installing packaged app from: https://marketplace.firefox.com: REINSTALL_FORBIDDEN" {file: "resource://gre/modules/Webapps.jsm" line: 2358}]

12-26 16:34:58.678 E/GeckoConsole( 9290): Content JS LOG at https://marketplace.cdn.mozilla.net/media/fireplace/js/include.js?b=1419286793073:4 in u/<: [installer] Install failed: REINSTALL_FORBIDDEN

So if the install failed, why is the reinstall not allowed?
Component: General → General
Product: Marketplace → Firefox OS
Version: Avenir → unspecified

Comment 3

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.