If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Flame][Browser]When you play a video on website after share a link by "Message", the "Browser" will auto close.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Browser
--
major
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: SandKing, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.0M unaffected, b2g-v2.1 wontfix, b2g-v2.1S wontfix, b2g-v2.2 wontfix, b2g-master wontfix)

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8541646 [details]
Bug video: 0140.MP4

[1.Description]:
[Flame][v2.0&v2.2][Browser]If user shares a link by "Message", then playing online video will lead to auto close of the browser
See log: "logcat_0140.txt"
See video:"0140.MP4".
Found Time:01:40

[2.Testing Steps]: 
1.  Launch Browser.
2.  Connect to a website.(Suggestion: www.youku.com).
3. Tap the "Menu" in this website and share this link by message(Menu->Share->Message).
4. When page load to Message, then press "Home" key.
5. Launch Browser again, and connect to an online video website, such as "www.youku.com".
6. Random broadcast a video.

[3.Expected Result]: 
6. The video should be played normal.

[4.Actual Result]: 
6. Sometimes the Browser will be closed automatically.

[5.Reproduction build]: 

Flame2.0 build
Gaia-Rev        01c32dcdc08b3c8fc8b3082870439fa2c1089f4f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/b41c344ed82d
Build-ID        20141225000210
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.033048
FW-Date         Thu Dec 25 03:30:58 EST 2014
Bootloader      L1TC00011880

Flame 2.1 :
Gaia-Rev        17c7ad2e4919a994f0844239b483116090412dee
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/39dfb662c82a
Build-ID        20141225001203
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.035108
FW-Date         Thu Dec 25 03:51:19 EST 2014
Bootloader      L1TC00011880

Flame 2.2:
Gaia-Rev        ab41c35eed35404b632a4841714b81b56364ba32
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2acb12da9813
Build-ID        20141225010202
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.043916
FW-Date         Thu Dec 25 04:39:27 EST 2014
Bootloader      L1TC00011880

Woodduck 2.0 build:
Gaia-Rev        add38992bbfb2bafca52ac1ce7f6231ac702675f
Gecko-Rev       8d951d9c4988e218ec08c6118a35c7faeb70af49
Build-ID        20141225143517
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1419478053
FW-Date         Thu Dec 25 11:27:57 CST 2014

[6.Reproduction Frequency]: 
occasionally Recurrence,8/20
TCID: Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8541654 [details]
Bug log: logcat_0140.txt
Looks like it had some memory pressure and was forced to quit.
What memory allocations was the flame set at?
Also, it looks like there was no SIM in the device.  Is that the case?
Flags: needinfo?(wangxin)
(Reporter)

Comment 3

3 years ago
Hi Naoki,
The memory allocations we set is 319M, and SIM card has on impact on reproducing this issue.
Flags: needinfo?(wangxin) → needinfo?(nhirata.bugzilla)
FYI, Hermes.  This might be a serious bug; I think it might need more investigation.
I think we need to see what's going on with in the dmesg log : adb shell dmesg

https://developer.mozilla.org/en-US/Firefox_OS/Platform/Out_of_memory_management_on_Firefox_OS
https://developer.mozilla.org/en-US/Firefox_OS/Debugging/Debugging_OOMs
Flags: needinfo?(nhirata.bugzilla) → needinfo?(hcheng)
Flags: needinfo?(wangxin)
Just to note, I believe that the SIM issue I saw in the log is bug 1114955.
I cannot reproduce this defect on either v2.1 or v2.2 with 319MB by following steps in video. Do I miss anything?
Flags: needinfo?(hcheng)
(Reporter)

Comment 7

3 years ago
Created attachment 8542468 [details]
Dmesg log: dmesg.txt

Hi Naoki,
Please  find Dmesg log from attachment. You can refer to it. 
This issue can hardly be reproduced on the latest version. So I changed to the older version in which this issue was found for the first time, and the issue is reproduced.

Flame 2.1 version:
Gaia-Rev        17c7ad2e4919a994f0844239b483116090412dee
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/39dfb662c82a
Build-ID        20141225001203
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.035108
FW-Date         Thu Dec 25 03:51:19 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(wangxin) → needinfo?(nhirata.bugzilla)
(Reporter)

Comment 8

3 years ago
Hi Naoki and Hermes,
Have you found that every time after you share links by message, the device will become slower and need more time to respond?
Any updates here? Can QA reproduce?
Created attachment 8545039 [details]
about-memory-3.tar.gz

I have reproduce it with a little different steps. I have to open browser 3 times then get crash.
  1. Launch Browser and browse youku. Then share it via message (not send out), and press home button.
  2. Launch Browser again, and browse youku. Then open one video (Not crash yet). Press home button.
  3. Launch Browser again (3rd time), and browser youku. Then open another video. This time, it crashes...

The attached compressed file was memory report collected before open the last video. Besides, when I wanted to collect memory report after opening the last video at step 3. "get_about_memory.py" told me two processes were killed:
  Warning: Child 9095 exited during memory reporting
  Warning: Child 9176 exited during memory reporting

In attached report, you can see "9095" is "Browser" and "9176" is "Preallocated app".
Yes, it's reproducible : <6>[16573.488001] zram: Error allocating memory for compressed page: 4013, size=4096
Flags: needinfo?(nhirata.bugzilla)
Odd.  When searching/using the Search for going to youku.com, two processes for Browser spawned.

nhirata-19333:B2G_Flame_kk_master nhirata$ ./profile.sh ps
  PID Name
----- ----------------
  218 b2g              profiler not running
  457 (Nuwa)           profiler not running
 1064 OperatorVariant  profiler not running
 1193 Homescreen       profiler not running
 1267 Find My Device   profiler not running
 1596 Browser          profiler not running
 1852 Browser          profiler not running
 1976 (Preallocated a  profiler not running
Created attachment 8548521 [details]
about-memory-0.zip

I got one prior to crashing.
Flags: needinfo?(anygregor)
This issue can be also repro on flame 3.0.

Flame3.0:
Build ID               20150227010229
Gaia Revision          7512026a377271a0cade12d70846557f0bc7781c
Gaia Date              2015-02-26 19:06:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c7968255c1ea
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150227.044026
Firmware Date          Fri Feb 27 04:40:36 EST 2015
Bootloader             L1TC000118D0
status-b2g-master: --- → affected

Comment 15

2 years ago
Hi Gregor,
Could you checl comment 10 to comment 14 from QA?
Thanks!

Comment 16

2 years ago
Hi Gergor,
Just a soft reminder, we are still waiting for your reply. Thanks!
Flags: needinfo?(anygregor)

Updated

2 years ago
Flags: needinfo?(anygregor)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #12)
> Odd.  When searching/using the Search for going to youku.com, two processes
> for Browser spawned.
> 
> nhirata-19333:B2G_Flame_kk_master nhirata$ ./profile.sh ps
>   PID Name
> ----- ----------------
>   218 b2g              profiler not running
>   457 (Nuwa)           profiler not running
>  1064 OperatorVariant  profiler not running
>  1193 Homescreen       profiler not running
>  1267 Find My Device   profiler not running
>  1596 Browser          profiler not running
>  1852 Browser          profiler not running
>  1976 (Preallocated a  profiler not running

This site does something like a window.open for video links. So it creates a new process.
I guess this is a general memory issue and as long as we don't have tools to detect memory regressions right away we can't do much here.
Flags: needinfo?(anygregor)

Comment 18

2 years ago
(In reply to Gregor Wagner [:gwagner] from comment #17)
> (In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from
> comment #12)
> > Odd.  When searching/using the Search for going to youku.com, two processes
> > for Browser spawned.
> > 
> > nhirata-19333:B2G_Flame_kk_master nhirata$ ./profile.sh ps
> >   PID Name
> > ----- ----------------
> >   218 b2g              profiler not running
> >   457 (Nuwa)           profiler not running
> >  1064 OperatorVariant  profiler not running
> >  1193 Homescreen       profiler not running
> >  1267 Find My Device   profiler not running
> >  1596 Browser          profiler not running
> >  1852 Browser          profiler not running
> >  1976 (Preallocated a  profiler not running
> 
> This site does something like a window.open for video links. So it creates a
> new process.
> I guess this is a general memory issue and as long as we don't have tools to
> detect memory regressions right away we can't do much here.

Sorry to jump in.

So, can we treat it as a known issue and mark it as "WONTFIX"?

Comment 19

2 years ago
Close as wontfix per comment 17.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-b2g-v2.1: affected → wontfix
status-b2g-v2.1S: --- → wontfix
status-b2g-v2.2: affected → wontfix
status-b2g-master: affected → wontfix
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.