All users were logged out of Bugzilla on October 13th, 2018

[Flame] When SIM 1 has no PIN lock and SIM 2 has pin lock then it will NOT display the "Enter pin" on start up

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: aaroncajes, Unassigned)

Tracking

({regression})

unspecified
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141225004001

Steps to reproduce:

1. SIM 1 has NO SIM LOCK
2. SIM 2 has SIM LOCK
3. Boot up flame


Actual results:

The "Enter your PIN" U.I is not being displayed.


Expected results:

It should display the "Enter your PIN" U.I so the user can use the second sim.
(Reporter)

Comment 1

4 years ago
Build identifier: 20141225160202
Git commit info: 2014-12-25 15:54:33 - 6f2b5a28
Build Number: 39
Can QA reproduce?
Keywords: qawanted
This issue reproduces on Flame 2.2, Flame 2.1.

Observed behavior: Device does NOT prompt for pin on SIM 2 after reboot if there are two SIMs inserted and SIM 1 does NOT have SIM pin enabled.

Furthermore, it doesn't prompt the user when in Phone app either. If I change default calling SIM to SIM 2 in Settings > SIM Manager and reboot, it still doesn't prompt for pin code, and when attempting to make a call it displays an error message saying there's a network error.

Device: Flame 2.2 Master
BuildID: 20150107051358
Gaia: cd5c88c77debee57c87da79a3995bb34521fb14b
Gecko: 206205dd8bd1
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1
BuildID: 20150107141959
Gaia: b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko: ae2af1ecd237
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

---------------

This issue does NOT reproduce on Flame 2.0. After rebooting with SIM 2 locked, device prompts for SIM 2 pin after unlocking. If user chooses to skip it at this screen, they'll be prompted again upon entering Phone app; and they'll be repeatedly prompted to enter pin code if they choose to skip it but then re-enter Phone app later.

Device: Flame 2.0
BuildID: 20150107143201
Gaia: 31d6c9422cd0a8213df9f96019c9ab7168ec3ab3
Gecko: 80bc2c4cd8ee
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
Status: UNCONFIRMED → NEW
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
Ever confirmed: true
Flags: needinfo?(ktucker)
Keywords: qawanted → regression
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 4

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.