when browsing in private and non-private modes, session restore doesn't work properly after a crash

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Jon Phillips, Unassigned)

Tracking

31 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Opera/9.80 (X11; Linux x86_64) Presto/2.12.388 Version/12.16

Steps to reproduce:

Open firefox.
Open pages in at least one other tab (so total number of pages is >1).
Start a private browsing session.
Go to your non-private session.
Change the currently active tab.
*Crash* firefox.
Reopen firefox.
Restore crashed session.


Actual results:

Only the active tab restored.  

If you didn't change tabs (so the last tab you used was a private one) it will not give you the option to restore your crashed session.  The appears to be a different manifestation of the same bug.


Expected results:

The entire non-private window should have restored.
(Reporter)

Updated

3 years ago
Component: Untriaged → Session Restore

Comment 1

3 years ago
Did you test with a clean profile? https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

In addition, could you post some crash links from about:crashes (bp-...).
Flags: needinfo?(994phij)
(Reporter)

Comment 2

3 years ago
(In reply to Loic from comment #1)
> Did you test with a clean profile?
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles
> 
> In addition, could you post some crash links from about:crashes (bp-...).

There's no issue with a clean profile, so I tried installing some addons and:
Ahah!  It's only an issue if you are using Vimperator and the session restore from Tab Mix Plus.

about:crashes has no relevant information (only one crash from 01/08/13 - I have this issue all the time).  When I click on the link it tells me 'Crash Not Found'.
Flags: needinfo?(994phij)

Comment 3

3 years ago
Ok, so I close the bug report as worksforme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.