If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

MOZ_NATIVE_JEMALLOC fails to autodetect with recent enough jemalloc in libc

RESOLVED FIXED in mozilla37

Status

()

Core
Build Config
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Jan Beich, Assigned: Jan Beich)

Tracking

Trunk
mozilla37
All
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Only jemalloc 3.5.x and 3.6.x have both nallocm() and nallocx(). FreeBSD 10.x has jemalloc-3.4.0 in libc while FreeBSD 11.0 (in development) has jemalloc-3.6.0. So, the build on FreeBSD with MOZ_JEMALLOC3=1 may either fail due to missing nallocx() or not detect nallocm() for MOZ_NATIVE_JEMALLOC the next time system jemalloc in 11.0 is upgraded[1].

In FreeBSD ports I'll switch Firefox 37.0 from MOZ_NATIVE_JEMALLOC to --enable-jemalloc, still with MOZ_JEMALLOC3=1. Not point sticking to old system jemalloc and fighting regressions from missing junk:free, etc.

[1] how-to: https://svnweb.freebsd.org/base/head/contrib/jemalloc/FREEBSD-upgrade?view=markup
(Assignee)

Comment 1

3 years ago
Created attachment 8541796 [details] [diff] [review]
fix

NPOTB. It'll disable MOZ_NATIVE_JEMALLOC on FreeBSD 10.x.
Attachment #8541796 - Flags: review?(mh+mozilla)
(Assignee)

Comment 2

3 years ago
https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=4ee8520e03ca
https://trillian.chruetertee.ch/freebsd-gecko/changeset/1798
Attachment #8541796 - Flags: review?(mh+mozilla) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/96a98f1d5aa8
Assignee: nobody → jbeich
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/96a98f1d5aa8
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
You need to log in before you can comment on or make changes to this bug.