Closed Bug 1115802 Opened 7 years ago Closed 6 years ago

Scrolling no longer working when tab mirroring from fennec.

Categories

(Firefox for Android Graveyard :: Screencasting, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox36 fixed, firefox37 fixed, fennec36+)

RESOLVED FIXED
Firefox 37
Tracking Status
firefox36 --- fixed
firefox37 --- fixed
fennec 36+ ---

People

(Reporter: rbarker, Assigned: blassey)

Details

Attachments

(1 file)

I looks like a recent update, possibly when desktop tab mirroring was enabled, has broken scrolling in tab mirroring in fennec. The mirror no longer shows what is on the screen but only the top of the page. Scrolling when tab mirroring on desktop nightly still works as expected.
Regression from bug 1112345?
tracking-fennec: --- → ?
Assignee: nobody → blassey.bugs
Attachment #8543062 - Flags: review?(snorp)
Attachment #8543062 - Flags: review?(snorp) → review+
https://hg.mozilla.org/mozilla-central/rev/7f82e95ceb05
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
Randall - Uplift please?
tracking-fennec: ? → 36+
(In reply to Mark Finkle (:mfinkle) from comment #4)
> Randall - Uplift please?

Scrolling isn't broken in 36. Are we going to uplift the broken code as well to require this?
(In reply to Randall Barker [:rbarker] from comment #5)
> (In reply to Mark Finkle (:mfinkle) from comment #4)
> > Randall - Uplift please?
> 
> Scrolling isn't broken in 36. Are we going to uplift the broken code as well
> to require this?

Yes, enough changes required for 36 have landed on top of the change that caused this regression that I think its best to just uplift them all
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #6)
> (In reply to Randall Barker [:rbarker] from comment #5)
> > Scrolling isn't broken in 36. Are we going to uplift the broken code as well
> > to require this?
> 
> Yes, enough changes required for 36 have landed on top of the change that
> caused this regression that I think its best to just uplift them all

Bug 1112345 broke scrolling and this fixes it. Are there any others I should request be uplifted? I have applied both to aurora, first 1112345 which broke scrolling as expected and then this one which fixed it. I was able cherry-pick both without conflict.
Comment on attachment 8543062 [details] [diff] [review]
scroll_mobile.patch

Approval Request Comment
[Feature/regressing bug #]:Tab Mirroring
[User impact if declined]:Will not be able to uplift additional patches need for Tab Mirroring.
[Describe test coverage new/current, TBPL]: Tab mirroring does not currently have any test coverage that I am aware of.
[Risks and why]: None known
[String/UUID change made/needed]:None known

Please note that this patch fixes scrolling in tab mirroring for Fennec that was broken by Bug 1112345 that has also been requested for uplift.
Attachment #8543062 - Flags: approval-mozilla-beta?
Attachment #8543062 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
This bug can not be verified because tab mirroring is disabled on Release channel in bug 1133012.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.