Closed Bug 1115808 Opened 7 years ago Closed 4 years ago

ilmessaggero.it doesn't redirect to mobile site

Categories

(Web Compatibility :: Mobile, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: niccolocantu94, Unassigned, NeedInfo)

References

()

Details

(Whiteboard: [country-it] [serversniff] [sitewait])

Attachments

(1 file)

User Agent: Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16
Build ID: 20141215131549

Steps to reproduce:

visit ilmessaggero.it

HTTP Request:

GET / HTTP/1.1
Host: ilmessaggero.it
User-Agent: Mozilla/5.0 (Mobile; rv:26.0) Gecko/26.0 Firefox/26.0



Actual results:

get desktop site

HTTP response:

HTTP/1.1 200 OK



Expected results:

redirect to m.ilmessaggero.it

expected HTTP response:

HTTP/1.1 302 Found
Location: http://m.ilmessaggero.it
Confirmed from http://arewecompatibleyet.com/screenshots/?cctld=it#21
Contacted by twitter on the official account https://twitter.com/Mte90Net/status/548881752689614849
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [country-it] [sitewait]
Whiteboard: [country-it] [sitewait] → [country-it] [serversniff] [sitewait]
Sent an email via their form.
Confirmed, it redirects to http://ilmessaggero.it/
Screenshot: http://i.imgur.com/ykys2Gg.png
resent a new tweet
I'm not able to reproduce the issue. Mobile page is displayed, also navigation on the site displays the mobile version correctly.

Tested with:
Browser / Version: Firefox Mobile Nightly 61.0a1 (2018-04-09)
Operating System: Google Pixel (Android 8.0.0) - 1080 x 1920 pixels (~441 ppi pixel density), 
Samsung Galaxy S7 Edge (Android 7.0) - 1440 x 2560 pixels (~534 ppi pixel density)

Niccolò, feel free to reopen the issue if you can still reproduce.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(niccolocantu94)
Resolution: --- → FIXED
Priority: -- → P3
Attached screenshot with the mobile version.
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.