If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

WebGL demo is throwing error message - Floating Point Textures

RESOLVED DUPLICATE of bug 1125445

Status

()

Core
Canvas: WebGL
--
major
RESOLVED DUPLICATE of bug 1125445
3 years ago
3 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox35 unaffected, firefox36+ fixed, firefox37+ fixed)

Details

(URL)

STR:

Open link:  http://madebyevan.com/webgl-water/ 
Note the error message:  Error: Rendering to floating-point textures is required but not supported

Found regression range:

Good: 20141124165728 74edfbf0e6a3 Good
Bad: 20141125035632 acde07cb4e4d bad

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=74edfbf0e6a3&tochange=acde07cb4e4d

Suspect patch: https://bugzilla.mozilla.org/show_bug.cgi?id=1102667 

Patch affected Canvas WebGL 

Regression testing from m-i builds in the range may be needed to be sure.

Comment 1

3 years ago
m-i
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d909e1fe5d13&tochange=b459d10124a8
status-firefox35: --- → unaffected
status-firefox36: --- → affected
status-firefox37: --- → affected
tracking-firefox36: --- → ?
tracking-firefox37: --- → ?
Flags: needinfo?(jgilbert)
Keywords: regressionwindow-wanted
This was blocked by https://github.com/KhronosGroup/WebGL/pull/789
It's unblocked now.
Flags: needinfo?(jgilbert)
Flags: needinfo?(jgilbert)
Regression, tracking. However, I don't think we would block the release for this
tracking-firefox36: ? → +
tracking-firefox37: ? → +

Updated

3 years ago
Duplicate of this bug: 1118284
This demo comes up in the tech scene regularly. It could affect perception of Firefox WebGL support. ex. https://encrypted.google.com/search?hl=en&q=site%3Anews.ycombinator.com%20webgl%20water
Jeff, Milan, do you have plans for this in 36? Thanks
Flags: needinfo?(milan)
Is this still a problem now that bug 1125445 landed?
Flags: needinfo?(milan)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1125445
(In reply to Milan Sreckovic [:milan] from comment #7)
> Is this still a problem now that bug 1125445 landed?

No longer a problem here, the demo works as expected, and no error message is displayed.

So, I guess 1125445 fixed the issue.
Thanks for checking.
Flags: needinfo?(jgilbert)
status-firefox36: affected → fixed
status-firefox37: affected → fixed
You need to log in before you can comment on or make changes to this bug.