Right click on close tab box

VERIFIED FIXED in mozilla1.1alpha

Status

SeaMonkey
Tabbed Browser
--
minor
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Niklas Mehner, Assigned: David Hyatt)

Tracking

Trunk
mozilla1.1alpha
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011122
BuildID:    2001112208

When having multiple tabs open, right clicking on the close tab button displays
the context menu AND closes a tab.

Reproducible: Always
Steps to Reproduce:
1.Start mozilla
2.Press Ctrl-T
3.Right click the close tab icon in the upper right of the tab bar

Actual Results:  A tab is closed and the context menu is displayed

Expected Results:  Only the context menu should be displayed.
(Reporter)

Comment 1

17 years ago
Created attachment 58961 [details] [diff] [review]
One line fix for the bug

Simple fix.
(Reporter)

Updated

17 years ago
Attachment #58961 - Attachment is obsolete: true
(Reporter)

Comment 2

17 years ago
Created attachment 58962 [details] [diff] [review]
The right patch to fix this bug.

Sorry, I attached the wrong patch.

Comment 3

17 years ago
shouldn't it be using oncommand?
(Reporter)

Comment 4

17 years ago
Created attachment 59040 [details] [diff] [review]
Patch using a toolbarbutton

oncommand did not work, because the closebox is an image, not a button. So I
changed it to be a toolbar button. Unfortunatly I only noticed later that bug 
104834 has a patch, that does exactly the same :( (stupid me).

Attaching the patch anyway, because it adds the functionality to disable the
button, when there is only one tab (which imho is needed to fix bug 109651).

Comment 5

17 years ago
Latest patch looks good. I'd be nice if cnecked-in sometime.
(Reporter)

Updated

17 years ago
Attachment #58962 - Attachment is obsolete: true
(Reporter)

Updated

17 years ago
Keywords: patch, review
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1
(Reporter)

Comment 6

17 years ago
This has been fixed by hewitts checkin last night (Works in linux build
2001121921). 

My patch is probably obsoleted by the checkin, which is unfortunate, because it
also fixed bug 109651.

Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
QA Contact: blaker → sairuh
verified fixed using 2002.01.29.1x comm bits on linux rh7.2, mac 10.1.2 and
win2k. right-clicking on the [X] close widget now only brings up the context
menu, and doesn't close the tab inadvertently.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.