zalando.it sends desktop site to Firefox OS

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
3 years ago
4 months ago

People

(Reporter: Niccolò "nicokant" Cantù [: nicokant], Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [country-it][serversniff][sitewait], URL)

Attachments

(1 attachment)

Created attachment 8541921 [details]
021-zalando.it.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20141215131549

Steps to reproduce:

visit zalando.it


Actual results:

get desktop site


Expected results:

get mobile site
Whiteboard: [country-it][serversniff][contactready]
(Reporter)

Comment 1

3 years ago
description
Significant difference in source code:
Response sent to Firefox OS has Content-Length: 20841
Response sent to Firefox Android has Content-Length: 0

Firefox Android redirected to http://m.zalando.it/, Firefox OS not redirected

Selected HTTP response headers:

Response for: 'Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1'
Response Status: 200
content-length: 20841
content-type: text/html;charset=UTF-8

Response for: 'Mozilla/5.0 (Android; Mobile; rv:26.0) Gecko/26.0 Firefox/26.0'
Response Status: 302
content-length: 0
location: http://m.zalando.it/
content-type: text/plain
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed from http://arewecompatibleyet.com/screenshots/?cctld=it#19
Contacted by twitter on the official account https://twitter.com/Mte90Net/status/549576746136502272
Whiteboard: [country-it][serversniff][contactready] → [country-it][serversniff][sitewait]
Response by Zalando https://twitter.com/ZalandoIT/status/549925562157137920
The problem was reported to their IT team.
resent a tweet

Comment 5

3 years ago
Fixed, now it redirects to http://m.zalando.it

Comment 6

3 years ago
(In reply to aroblu94 from comment #5)
> Fixed, now it redirects to http://m.zalando.it

Screenshot: http://i.imgur.com/Fqm317s.png
Bug resolved as shown by comment #6
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.