XBL binding not attaching in 0.9.6

VERIFIED INVALID

Status

()

--
major
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: collard, Assigned: hyatt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011121
BuildID:    2001112111

An XBL binding that attaches fine in 0.9.5
Build ID: 2001101202 (and some previous releases)
now doesn't attach in this 0.9.6 release.

This page should have two lines of text
Description outside of XBL
Description inside of XBL

The first description is directly on the XUL page (txbl.xul)
while the other is inside the XBL binding (txbl.xml). 

Reproducible: Always
Steps to Reproduce:
1. Open http://www.cs.kent.edu/~lab51/txbl/txbl.xul in 0.9.6
2.
3.

Actual Results:  Text appeared:

Description outside of XBL

Expected Results:  Text appeared:

Description outside of XBL
Description inside of XBL
(Reporter)

Comment 1

17 years ago
Created attachment 58969 [details]
Zip file of testcase

Zip file of testcase including:

txbl.xul
txbl.xml
txbl.css

Comment 2

17 years ago
<bindings 
  id="xulbindings"
  xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xbl"
  xmlns:xul="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">

Umm ...

  xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xbl"

should be 

  xmlns:junk="http://www.mozilla.org/xbl"

as it's always been. 

(Not nearly as colorful as the xul namespace, but we're trying to act more 
grownup, and standards-official-like :-]).

Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
> should be 
>
>   xmlns:junk="http://www.mozilla.org/xbl"

Doh! Copy-paste error.

should be 

  xmlns="http://www.mozilla.org/xbl"



Status: RESOLVED → VERIFIED

Comment 4

17 years ago
By the way, yes, this did work in the past, but that was because we didn't 
really care what the default namespace was declared to be. But the processing
became stricter, and the 'there.is.only.xbl' namespace was never valid.
You need to log in before you can comment on or make changes to this bug.