Implement storage panel of addon debugger for chrome.storage

RESOLVED DUPLICATE of bug 1363008

Status

P2
normal
RESOLVED DUPLICATE of bug 1363008
4 years ago
4 months ago

People

(Reporter: bruant.d, Assigned: miker)

Tracking

(Blocks: 1 bug)

36 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [todo-mr])

Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
Comment hidden (obsolete)
(In reply to Tom Tromey :tromey from comment #4)
> (In reply to David Bruant from comment #3)
> > WebExtensions have a storage API that will need to be debugged
> > https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/storage
> > 
> > I'm not up-to-date on the WebExtension developer experience right now. Is
> > there a Storage Inspector for WebExtensions?
> 
> I don't know, but Mike might.

Yes, there is but it only works with IndexedDB right now.

Simple storage is no longer needed.

David is referring to the chrome.storage space inside Web Extension Code... we need to add that to the Storage Inspector so let's re-purpose this bug.
Flags: needinfo?(mratcliffe)
Summary: Implement storage panel of addon debugger for simple-storage → Implement storage panel of addon debugger for chrome.storage
Priority: -- → P2
No longer blocks: 899054
Depends on: 1312444
Blocks: 1312444
No longer depends on: 1312444
Whiteboard: [papercut-mr]
Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Filter on Brobdingnagian.
Whiteboard: [papercut-mr] → [todo-mr]
Assignee: ntim.bugs → nobody
Status: ASSIGNED → NEW
Assignee: nobody → mratcliffe
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1363008

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.