Console eval broken with servers before 37 (missing evaluateJSAsync)

RESOLVED FIXED in Firefox 37

Status

DevTools
Console
RESOLVED FIXED
4 years ago
6 days ago

People

(Reporter: jryans, Assigned: bgrins)

Tracking

({regression})

Trunk
Firefox 37
regression

Firefox Tracking Flags

(firefox37+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

In bug 1088861, the console changed to use a new "evaluateJSAsync" actor method.

However servers before 37 don't have this method, so console eval is now broken for them.

Traits or similar feature detection should be used client-side to detect if this server method is available before use.
(Reporter)

Comment 1

4 years ago
Brian, would you be able to look at this since you worked on bug 1088861?
Flags: needinfo?(bgrinstead)
(Reporter)

Comment 2

4 years ago
[Tracking Requested - why for this release]: DevTools console broken when connecting to any previous version, e.g. all B2G simulators, old Fennec, etc.
tracking-firefox37: --- → ?
(Assignee)

Comment 3

4 years ago
(In reply to J. Ryan Stinnett [:jryans] from comment #1)
> Brian, would you be able to look at this since you worked on bug 1088861?

Yes, I'll fix this
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Flags: needinfo?(bgrinstead)
(Assignee)

Comment 4

4 years ago
Created attachment 8544116 [details] [diff] [review]
evaluateJSAsync-backwards-compat.patch

What do you think?  I tested with a simulator and all seemed well.
Attachment #8544116 - Flags: review?(jryans)
(Reporter)

Comment 5

4 years ago
Comment on attachment 8544116 [details] [diff] [review]
evaluateJSAsync-backwards-compat.patch

Review of attachment 8544116 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks!

::: toolkit/devtools/webconsole/client.js
@@ +136,5 @@
>     * See evaluateJS for parameter and response information.
>     */
>    evaluateJSAsync: function(aString, aOnResponse, aOptions = {})
>    {
> +    // Pre-37 clients need to do sync evaluation.

Nit: Pre-37 servers don't support async evaluation
Attachment #8544116 - Flags: review?(jryans) → review+
(Assignee)

Comment 6

4 years ago
Created attachment 8544118 [details] [diff] [review]
evaluateJSAsync-backwards-compat.patch

Updated comment
Attachment #8544116 - Attachment is obsolete: true
Attachment #8544118 - Flags: review+
(Assignee)

Comment 7

4 years ago
Pushed to try: https://tbpl.mozilla.org/?tree=Try&rev=881ed49714fb
Keywords: checkin-needed
tracking-firefox37: ? → +
(Assignee)

Comment 8

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/0dd788e4b214
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/0dd788e4b214
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-firefox37: --- → fixed
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 37

Updated

6 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.