Closed Bug 11164 Opened 21 years ago Closed 21 years ago

Mail window comes up blank

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3, major)

x86
Linux

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 11165

People

(Reporter: akkzilla, Assigned: sspitzer)

Details

I started seeing this yesterday morning before the mail/news carpool, but
decided to wait to file a bug in case the carpool fixed it.  It didn't.
apprunner -mail on my linux machine comes up blank -- approximately the right
size but with no content in the window.  This is on a clean build, pulled into a
freshly-made directory this morning.

On the same build, I can't load any pages into the browser window either (it
hangs while trying to load them) though the browser and editor both show
chrome.  So this may be a necko problem.
When was your build this morning?  My Linux clobber build from around 10:15am on
8/3 is working fine with apprunner -mail, I was unable to run it yesterday so I
don't know if anything has changed.  Seth or Alec, any suggestions? Are you guys
seeing this?
I saw this problem on a build from yesterday pulled about 11am, and a build from
today pulled at about 10am.
akkana:  are you running from the debugger?
Hmm.  I can also load browser pages. But, I did notice something.  I can't
always run this.  Sometimes I get Load failed on various functions in
raptorhtml.so.  But when I can run this, it's working.  I don't know much about
different versions of Linux.  I'm not running the most recent one.  Could this
be making a difference?
No -- I normally run outside the debugger unless there's some reason to run
inside it.
I just noticed that it's trying to start with
http://people.netscape.com/sspitzer/startpage.html.  That's probably the cause
of the problem -- the browser can't load any http urls at all, yesterday or
today (I filed that as a separate bug).  Is there some local chrome file I could
try instead of that URL?
I can load that start page just fine.

I can load http:// urls fine, too.

putterman, that problem you are seeing is something alecf and blizzard are
working on.

see bug #8849
I'm on rh 6.0, though.
is this a 5.2 issue?
I'm on 5.2, 2.2.6 kernel, glibc-2.0.7-36 (blizzard's attempt to patch the 8849
thread reentrancy problem).
Can we find a better owner than Phil for this? Or at least change the summary
and product to reflect the actual problem?
Assignee: phil → sspitzer
Seth, could you take a look at this?  It sounds like this is probably a
bug outside of mailnews in which case we can just reassign it.  Akkana, is this
still happening to you with today's build?  As far as I know I'm using RH 5.2,
but unless it's part of the build system, I'm not using a new glibc.
It's still happening in today's build.  My off-the-cuff guess is that it stems
from the same causes as 11165 (can't load any pages in the browser) and further
that both of these stem from the reentrancy issues in 8849 (the mail window may
be getting harder hit -- not showing chrome while the browser window does --
because it's trying to load several pages at once from the net).
Status: NEW → ASSIGNED
accepting bug.

akkana, can I come down and see what's going on?
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Sure enough, the workaround for the netlib problem also fixes the mail problem
(thanks to Seth and Gagan's detective work).  See that bug for further
investigation.

*** This bug has been marked as a duplicate of 11165 ***
Status: RESOLVED → VERIFIED
per akkana's comments, I'm going to mark this verified as duplicate.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.