Layout: form element inherits width from previous image

VERIFIED DUPLICATE of bug 48237

Status

()

Core
Layout: Form Controls
P2
normal
VERIFIED DUPLICATE of bug 48237
17 years ago
16 years ago

People

(Reporter: Lloyd Wood, Assigned: rods (gone))

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Rather than using the minimum width needed to display a list of selectable menu
options, it's possible to make the option menu use the width of a
previously-specified image instead. This can rather mess up page layout.

Demonstrated in provided URL and shown for the Mozilla 0.96 release in the
screenshot I'm attaching. I've also seen this behaviour in previous Mozilla
releases I've used.
(Reporter)

Comment 1

17 years ago
Created attachment 58991 [details]
screenshot (png) showing misdrawn form menu with width of image.
(Reporter)

Comment 2

17 years ago
Image attached is probably jpeg, not png (I didn't have my screengrabber
configured correctly) but the image seems to be retrieved okay by mozilla.

I tried to edit attachment info to reflect this, but I'm apparently not
authorised to edit information for my own attachments. Which begs the question
why the Actions: Edit link is shown there for the attachment... that a bug in
bugzilla?

Comment 3

17 years ago
Build ID: 2001 11 23 03. Windows 2000.

Layout is quite different for me, see attachment 2 [details] [diff] [review].

Comment 4

17 years ago
Created attachment 59014 [details]
windows screendump

Comment 5

17 years ago
Ooops. Bugzilla created the link to "a t t a c h m e n t    2" for me.
Please ignore that link. I wasn't aware of this transmogrifying feature...
(Reporter)

Comment 6

17 years ago
Svante's attached screenshot shows the same behaviour - the width of the form 
option select element is overly large compared to the small text it contains, 
and again matches the width of the image at right.

Svante claims that the layout is different is simply because Svante's browser 
window is far, far, wider (presumably because Svante has spent a lot of money 
on a high-resolution monitor), so that the form element can be drawn at 
the side without overlapping the picture and table. A narrower browser window 
would show Svante exactly the same positioning behaviour, consistent 
crossplatform.

Svante's screenshot is imo clear confirmation of the problem; the form pulldown
is consistently too wide for the text it contains, and consistently matches the 
width of the image.
It looks like the <select> is leaving space for the floater...  ccing waterson
and rods; I'm not really sure which of floaters and form controls is
responsible...

Putting a "clear: right" on the <form> makes the layout correct.   Putting a
"clear: right" on the select does nothing (which makes sense to me -- it's not a
block).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 9

17 years ago
Adding this minor clarification on the previous comment, since it confused me...

L.

Lloyd wrote:

> There's a weird ctrl-R in your comments; shows as the usual unicode
> block thing in mozilla. what's it meant to be?

That was... a ctrl-R.  I hit it by accident when I was typing in the
comment, and apparently ns4 (which I was using for various reasons)
decided to not show it but to send it...

Boris

Comment 10

17 years ago
reassigning to rods so he can take a look at this
Assignee: attinasi → rods
Component: Layout → HTML Form Controls
QA Contact: petersen → madhur
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1
(Assignee)

Updated

17 years ago
Priority: -- → P1
Target Milestone: mozilla1.0.1 → Future
(Assignee)

Updated

16 years ago
Priority: P1 → P2

Updated

16 years ago
QA Contact: madhur → tpreston
Wow.  This bug is _old_

*** This bug has been marked as a duplicate of 48237 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 12

16 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.