[Flame]]The JPEG pictures which are taken by HTC smart phone can't be recognized in Gallery.

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: zikui.yang, Assigned: djf)

Tracking

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 verified, b2g-v2.1S fixed, b2g-v2.2 verified)

Details

Attachments

(6 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.2][Gallery]Import some other device's JPEG pictures to FFOS storage or transfer them by BT to FFOS storage.Device can't recognize the JPEG pictures.
Attchment: IMAG0595.jpg,  IMAG0596.jpg  and logcat.txt
Happen time:3:32


[2.Testing Steps]: 
Precondition:Import some JPEG pictures which are taken by HTC smart phone(HTC one)into FFOS phone storage.(I have uploaded the JPEG pictures as attachment, please refer to IMAG0595.jpg and IMAG0596.jpg)
1.Launch Gallery


[3.Expected Result]: 
1.The JPEG pictures which are taken by HTC smart phone can be shown in Gallery.

[4.Actual Result]: 
1.The JPEG pictures which are taken by HTC smart phone can't be shown in Gallery.

[5.Reproduction build]: 
Gaia-Rev        bdedbaf9f18a43c091ede770407d68d38582fe29
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/8850aa0f5332
Build-ID        20141229010215
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID:Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8542513 [details]
IMAG0595.jpg

Testfile for issue
(Reporter)

Comment 2

4 years ago
Created attachment 8542514 [details]
logcat.txt

log for issue
(Reporter)

Comment 3

4 years ago
Created attachment 8542515 [details]
IMAG0596.jpg

Testfile for issue
Hi David, Could you help with this, thanks.

Hi Elie, Could you also check if we can reproduce this on V2.1, thanks.
Flags: needinfo?(dflanagan)
(Assignee)

Comment 5

4 years ago
I can reproduce this with the attached image. It appears that the code in shared/js/media/image_size.js is not recognizing the file as a jpeg, so we're rejecting it because the file is too big. Taking this bug to investigate.
Assignee: nobody → dflanagan
Flags: needinfo?(dflanagan)
(Assignee)

Comment 6

4 years ago
Created attachment 8545451 [details] [review]
link to patch on github

Punam,

This patch changes the EXIF orientation code in the shared jpeg_metadata_parser.js file so that it doesn't throw an error for unexpected values and instead just ignores those values.
Attachment #8545451 - Flags: review?(pdahiya)
(Reporter)

Comment 7

4 years ago
(In reply to Eric Chang [:ericcc] [:echang] from comment #4)
> Hi David, Could you help with this, thanks.
> 
> Hi Elie, Could you also check if we can reproduce this on V2.1, thanks.

Hey Eric,this issue exist on flame2.1:
Gaia-Rev        b04a8cb7b2482e0a44e6702b48c42283a00b5b1e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/99cea2c818f6
Build-ID        20150107001244
Version         34.0

Have been add Mike to CC list.
status-b2g-v2.1: --- → affected
Flags: needinfo?(echang)
(Reporter)

Comment 8

4 years ago
Created attachment 8545631 [details]
logcat.txt

log for this issue on flame2.1 ,build version refer to comment7
Comment on attachment 8545451 [details] [review]
link to patch on github

Thanks David, tested and patch fixes the issue of attached images not showing up in gallery. IMO it's a good patch to uplift to 2.1.
Attachment #8545451 - Flags: review?(pdahiya) → review+
(Assignee)

Comment 10

4 years ago
Landed on master: https://github.com/mozilla-b2g/gaia/commit/b875c1ddb0a024d1d375d549d0a0268adb27ae80
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
status-b2g-v2.2: affected → fixed
(Assignee)

Comment 11

4 years ago
Comment on attachment 8545451 [details] [review]
link to patch on github

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 

Not a regression. JPEG images from HTC phones have slightly malformed metadata and we do not ignore it gracefully.

[User impact] if declined:

Certain photos will not be viewable in gallery. We will have compatibility problems with some HTC phones.

[Testing completed]:

manual testing done on 2.2 and 2.1

[Risk to taking this patch] (and alternatives if risky):

It is a very simply patch. Basically zero risk.

[String changes made]:

None.
Attachment #8545451 - Flags: approval-gaia-v2.1?(bbajaj)
Comment on attachment 8545451 [details] [review]
link to patch on github

Approving given the super low risk here.
Attachment #8545451 - Flags: approval-gaia-v2.1?(bbajaj) → approval-gaia-v2.1+

Updated

4 years ago
Keywords: verifyme
(Reporter)

Comment 13

4 years ago
Hi Eric,
this issue still exist on Flame 2.2:
Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bb8d6034f5f2
Build-ID        20150111010223
Version         37.0a1
reproduce       5/5
(Reporter)

Comment 14

4 years ago
Created attachment 8547929 [details]
logcat_0633.txt

Happen time 6:33
v2.1: https://github.com/mozilla-b2g/gaia/commit/6957ac8a322234ec99c8abb7cc18dc6a2e0176db
status-b2g-v2.1: affected → fixed
Target Milestone: --- → 2.2 S4 (23jan)
(Reporter)

Comment 16

4 years ago
This issue verified successfully on flame2.2:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2c37b89bdd86
Build-ID        20150112153951
Version         37.0a2
status-b2g-v2.2: fixed → verified
Hi Elie, Thanks for your help, could you also check that on v2.1 maybe tomorrow after the patch is all the way to the PVT build, thanks.
Flags: needinfo?(echang) → needinfo?(zikui.yang)
(Reporter)

Comment 18

4 years ago
(In reply to Eric Chang [:ericcc] [:echang] from comment #17)
> Hi Elie, Thanks for your help, could you also check that on v2.1 maybe
> tomorrow after the patch is all the way to the PVT build, thanks.

This issue verified successfully on flame2.1:
Gaia-Rev        6957ac8a322234ec99c8abb7cc18dc6a2e0176db
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6600eba54256
Build-ID        20150114001300
Version         34.0
Reproduce rate   0/5
status-b2g-v2.1: fixed → verified
Flags: needinfo?(zikui.yang)
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

4 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.