test failures due to hard-coded dates

RESOLVED FIXED

Status

Input
General
P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: willkg, Assigned: willkg)

Tracking

Details

(Whiteboard: u=dev c=codequality p=1 s=input.2014q4)

We're seeing new test failures:


======================================================================
FAIL: fjord/feedback/tests/test_api.py:PublicFeedbackAPITest.test_both_date_end_and_date_start_with_no_date_delta
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/willkg/mozilla/fjord/fjord/feedback/tests/test_api.py", line 202, in test_both_date_end_and_date_start_with_no_date_delta
    ['2014-07-03T00:00:00', '2014-07-02T00:00:00']
  File "/home/willkg/mozilla/fjord/fjord/feedback/tests/test_api.py", line 143, in _test_date
    eq_(len(json_data['results']), len(expectedresponse))
AssertionError: 1 != 2

======================================================================
FAIL: fjord/feedback/tests/test_api.py:PublicFeedbackAPITest.test_date_delta_with_date_end
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/willkg/mozilla/fjord/fjord/feedback/tests/test_api.py", line 165, in test_date_delta_with_date_end
    ['2014-07-03T00:00:00', '2014-07-02T00:00:00'])
  File "/home/willkg/mozilla/fjord/fjord/feedback/tests/test_api.py", line 143, in _test_date
    eq_(len(json_data['results']), len(expectedresponse))
AssertionError: 1 != 2

======================================================================
FAIL: fjord/feedback/tests/test_api.py:PublicFeedbackAPITest.test_date_delta_with_date_end_and_date_start
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/willkg/mozilla/fjord/fjord/feedback/tests/test_api.py", line 178, in test_date_delta_with_date_end_and_date_start
    ['2014-07-03T00:00:00', '2014-07-02T00:00:00'])
  File "/home/willkg/mozilla/fjord/fjord/feedback/tests/test_api.py", line 143, in _test_date
    eq_(len(json_data['results']), len(expectedresponse))
AssertionError: 1 != 2

======================================================================
FAIL: fjord/feedback/tests/test_api.py:PublicFeedbackAPITest.test_date_delta_with_date_start
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/willkg/mozilla/fjord/fjord/feedback/tests/test_api.py", line 171, in test_date_delta_with_date_start
    ['2014-07-03T00:00:00', '2014-07-02T00:00:00'])
  File "/home/willkg/mozilla/fjord/fjord/feedback/tests/test_api.py", line 143, in _test_date
    eq_(len(json_data['results']), len(expectedresponse))
AssertionError: 1 != 2

======================================================================
FAIL: fjord/feedback/tests/test_api.py:PublicFeedbackAPITest.test_date_start
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/willkg/mozilla/fjord/fjord/feedback/tests/test_api.py", line 152, in test_date_start
    '2014-07-02T00:00:00'])
  File "/home/willkg/mozilla/fjord/fjord/feedback/tests/test_api.py", line 143, in _test_date
    eq_(len(json_data['results']), len(expectedresponse))
AssertionError: 2 != 3


I looked at one of them and I suspect the problem is from hard-coded dates and the API being restricted to the last 180 days.
This blocks development, so I'm going to grab it now and work on it.
Assignee: nobody → willkg
Status: NEW → ASSIGNED
Whiteboard: u=dev c=codequality p= s=input.2015q1 → u=dev c=codequality p= s=input.2014q1
Set points and fix sprint.
Whiteboard: u=dev c=codequality p= s=input.2014q1 → u=dev c=codequality p=1 s=input.2014q4
Landed in master in https://github.com/mozilla/fjord/commit/f9f789a837c8489f95a114af090e8aafc911a082

Jenkins is cool with it, so marking it FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.