Closed Bug 11165 Opened 21 years ago Closed 20 years ago

Browser can't load any http pages

Categories

(Core :: Networking, defect, P3, major)

x86
Linux
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: akkzilla, Assigned: gagan)

References

Details

The apprunner browser window comes up with the correct chrome, but it can't load
any http pages.  If I type a url in the url bar, the host is apparently
resolved, I see messages suggesting that the hostname was resolved, then a
background color is loaded, then the app hangs.  With
http://www.mozillazine.org, stdout says:
FindShortcut: in='http://www.mozillazine.org'  out='null'
Begin parsing...
Area(td)(0)@0x8436710: WARNING: max-element-size:2790,1350 desired:2790,0
maxSize:1073741824,1073741824
With http://warp, stdout says:
FindShortcut: in='http://warp'  out='null'
Begin parsing...
End parse elapsed: 122ms
Begin parsing...
End parse elapsed: 185ms
Begin parsing...
End parse elapsed: 377ms
Document: Done (0.936 secs)

In both cases, the page isn't drawn and the browser is hung.
Target Milestone: M9
Putting on M9 radar.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Akkana: could you verify this with the latest build? No one else seems to have
this problem. Marking WorksForMe for now...
Status: RESOLVED → REOPENED
Reopening -- I still see this on Wed. morning's fresh build.  It loaded part of
the mozillazine start page (the title and a couple of images), then hung.
Resolution: WORKSFORME → ---
*** Bug 11164 has been marked as a duplicate of this bug. ***
Turns out we're hanging on a poll that never returns.  Undefining
USE_POLLABLE_EVENT in netwerk/base/src/nsSocketTransportService.h is a
workaround which fixes all the problems -- the browser can load pages, mailnews
loads its chrome as well as folders and messages, and TestProtocols can load
pages.
Forgot to mention: I saw this on both blizzard's specially hacked glibc-2.0.7-36
and on the regular glibc-2.0.7-32 off spoonfeed.
I have been building very often over the past few days
and have not seen this at all. RH5.2.  I do still see
the dlopen() startup problem though.
I also don't see this at all, what I can think of is a very strange timing
problem.
Akkana, are you seeing this still?  Should this be a m9 blocker?
In Monday morning's build, I'm not seeing the problem any more.
Severity: blocker → major
Target Milestone: M9 → M10
downgrade to major, M10, let's wait a bit
and make sure we're clear of this before
marking it worksforme.
Status: REOPENED → RESOLVED
Closed: 21 years ago20 years ago
Resolution: --- → WORKSFORME
marking worksforme. Reopen if you continue to have problems.
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
Sorry for the spam, changing QA contact.
QA Contact: paulmac → tever
old bug, this has been working for awhile now
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.