If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

Marketing
Design
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Liz Hull, Assigned: mternoway)

Tracking

Details

Attachments

(3 attachments, 3 obsolete attachments)

(Reporter)

Description

3 years ago
>>Project/Request Title:
Privacy Day Twitter Chat 

>>Project Overview:
We’d love three Twitter graphics to help promote our #PrivacyChat (a Twitter chat we’ll be hosting on Privacy Day). In order to ensure the success of the chat, we – and other formal participants – need to publicize the chat in advance, and these graphics will aid us in doing so. Detail about the three graphics:

1. A version w/ the Firefox logo for Firefox to use in advance of the chat; 
2. A version w/ the Mozilla logo for Mozilla to use in advance of the chat; and
3. A non-logo’d version for our formal participants to use in advance of the chat (i.e. Duck Duck Go, Privacy International, Ello, etc.).

>> Creative Help Needed:
Copy:    No 
Design:  Yes 
Video:   No 
Other:  No

>>Creative Specs:
1760px × 800px

>>CTA and Design:
All three graphics should have the same look and feel (with the only difference being the logos or lack of logos). Copy for graphic:

Join us on Privacy Day for a 
Twitter #PrivacyChat
January 28
11am PT, 2pm ET, 7pm UTC

If this feels like too much copy in layout, we could alternately do:

#PrivacyChat
January 28
11am PT, 2pm ET, 7pm UTC

>>Creative Due Date:
2015-01-08

>>Launch Date:
Not provided

>>Mozilla Goal:
Firefox Browser

>>Mozilla Creative Collective:
No

>>Points of Contact:
ehull@mozilla.com, mjkelly@mozilla.com, mthayer@mozilla.com
(Reporter)

Updated

3 years ago
Blocks: 1109324

Comment 1

3 years ago
Thanks, Liz.

I'm going to assign this to Matt, but is there any flexibility in the due date?

I'm also adding Ty, who's designing the privacy site, for reference.
Assignee: jbalaco → mternoway

Comment 2

3 years ago
(In reply to Matej Novak [:matej] from comment #1)
> Thanks, Liz.
> 
> I'm going to assign this to Matt, but is there any flexibility in the due
> date?
> 
> I'm also adding Ty, who's designing the privacy site, for reference.

I think we have some flexibility on the due date, though would be awesome to get the graphics to the chat participants by the 15th at the latest so that they can start using them.

Comment 3

3 years ago
(In reply to mthayer@mozilla.com from comment #2)
> (In reply to Matej Novak [:matej] from comment #1)
> > Thanks, Liz.
> > 
> > I'm going to assign this to Matt, but is there any flexibility in the due
> > date?
> > 
> > I'm also adding Ty, who's designing the privacy site, for reference.
> 
> I think we have some flexibility on the due date, though would be awesome to
> get the graphics to the chat participants by the 15th at the latest so that
> they can start using them.

Great, thanks. That sounds totally doable to me.

Matt, let us know if you have any questions or concerns.

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

3 years ago
Created attachment 8546774 [details]
firefox_privacyDay_january_twitter-timeline.png

Hi all, let me know what you think of this idea for the Privacy Day invite Twitter post. Pretty straight forward...I've utilized an open envelope to deliver the message. The Firefox logo can easily be replaced with the Mozilla logo, or would work without any as well. The corner sticker is a play off of the mask icon that we use to represent the concept of privacy in many cases.

MT

Comment 5

3 years ago
Hi Mat, also reposting my comment from a separate conversation with Liz about the mask: "using something associated with a FF feature is not ideal but not a deal-breaker for me. Not opposed to using the mask as our main visual but would also be interested in seeing other options, including one that leans toward personal rights/freedom rather than concealment/secrecy"

Would you be able to offer alternatives before we make a final call? Would like this to become the main visual for the other campaign assets. Thanks!
(Reporter)

Comment 6

3 years ago
Hey MT! Thanks so much for turning this around. Few points of feedback: 

Can we see a version that just has the following text? 

#PrivacyChat

January 28
11am PT, 2pm ET, 7pm UTC

Without the invitation copy, the envelope might be obsolete. Also, I would love to see bolder colors like the ones from fx10: http://mzl.la/1y3O5U0. I think the mask works since the chat is hosted by Firefox, even though we'll be removing the actual Firefox logo for our participants to share.
(Assignee)

Comment 7

3 years ago
Thanks for the feedback on the invite. One thing to note is, internally we are still establishing a 'main' visual to represent Privacy Day. Currently Ty is working on this, and I will be leveraging creative from him and adapting to this specific request. The idea of the envelope/letter is a unique graphic to the social media invite, I don't see it being used beyond this request. Hope to have an update to show soon. 

Matt
(Reporter)

Comment 8

3 years ago
Awesome. Thanks!
(Assignee)

Comment 9

3 years ago
Hi all, a question that has been brought up internally, that I'm hoping can be clarified here. Is there an actual need to brand this day from our own perspective? We're playing around with various imagery and icons that represent privacy, but am wondering if it makes sense to make use of the already established logo for our creative > http://cl.ly/image/3S2a3r3i4325. This could be used as a visual cue point in accompany with other creative visuals. Example: Having the DPD logo appear as a stamp on our Privacy Day invite > http://cl.ly/image/0s1G0Q2a0p3N

Let me know what you think.
Thanks,
Matt

Comment 10

3 years ago
I'd +1 using the set brand for the day to keep it consistent, for sure. Good call - let's you and I discuss how we can incorporate that into the work.

Comment 11

3 years ago
There are two issues with using this logo:
- l10n (it's only available in English and French)
- a number of our assets will run post-privacy day.

So while this could work for the Twitter chat (English only and active in the lead-up to and on Privacy Day), I am not sure if this is the best asset for the overall campaign identity. What do you think?

Comment 12

3 years ago
Yeah, text within the logo isn't ideal.

We're looking at making a mashup mark using our privacy mask on the interior of the mobius strip outer portion of their logo. Best of both worlds and no text used.

More to come, stay tuned. :)
(Assignee)

Comment 13

3 years ago
Created attachment 8548947 [details]
firefox_privacyDay_january_twitter-timeline.png

Hi guys, I've updated the invite to reflect the recent conversations around the direction for DPD branding.  Internally we are using red, based off of Ty's home page layout, as well as using a 'mask within a shield' icon as the unifying element across all Mozilla DPD creative.  There will be two versions of this branded icon, a full colour detail and a flat one colour (as in this example). In this case the flat one colour plays into the idea of a stamped effect on a letterhead. If all is good with this layout, I will be translating the design for the FB invite.

Thanks,
Matt
Attachment #8546774 - Attachment is obsolete: true
(Assignee)

Comment 14

3 years ago
Created attachment 8549608 [details]
firefox_privacyDay_january_twitter-timeline.png

sorry, realized I had the wrong hashtag on the previous post. Updated in this one.
Attachment #8548947 - Attachment is obsolete: true
(Assignee)

Comment 15

3 years ago
Created attachment 8549700 [details]
firefox_privacyDay_january_twitter-timeline.png
Attachment #8549608 - Attachment is obsolete: true
(Reporter)

Comment 16

3 years ago
Awesome! Greg, is this good to go? 

If so, can I also have a version sans the Firefox logo to send to our Twitter chat participants? 

Thanks!
Flags: needinfo?(gjost)

Comment 17

3 years ago
Looks good to me! Thanks!
Can we also have a version with the Mozilla logo? Believe Paul is going to need those for the MoFo social posts. Paul do you confirm?
Flags: needinfo?(gjost) → needinfo?(paulj)

Comment 18

3 years ago
Confirmed - would be great to have a version of this with the Mozilla logo.
Flags: needinfo?(paulj)
I think a version with the Mozilla workmark shouldn't be a problem (Matt, please confirm), but without any logo is going to be harder because of the way it's designed. Also, if we're the ones sponsoring and moderating it, it feels odd to me to have one without any Firefox or Mozilla branding.
(Assignee)

Comment 20

3 years ago
Created attachment 8549764 [details]
mozilla_privacyDay_january_twitter-timeline.png

Not a problem to place a Mozilla logo...I've attached an example.
(Reporter)

Comment 21

3 years ago
Matej - we want our participants to feel ownership over the chat, too, so they will promote it to their followers. Firefox may be moderating, but these will be the people really elevating the conversation with their answers. Since we're not putting any advertising behind it, having their help in publicizing it will be crucial. I wouldn't want them not to share it because it has our logo. 

We will be sharing the Firefox branded one from @Firefox, of course, but will be sending the un-branded one to DuckDuckGo, Privacy International, Intel, etc., so they can post direct to their feeds. 

Thoughts?
(In reply to Liz Hull from comment #21)
> Matej - we want our participants to feel ownership over the chat, too, so
> they will promote it to their followers. Firefox may be moderating, but
> these will be the people really elevating the conversation with their
> answers. Since we're not putting any advertising behind it, having their
> help in publicizing it will be crucial. I wouldn't want them not to share it
> because it has our logo. 
> 
> We will be sharing the Firefox branded one from @Firefox, of course, but
> will be sending the un-branded one to DuckDuckGo, Privacy International,
> Intel, etc., so they can post direct to their feeds. 
> 
> Thoughts?

I'm mostly worried how much it's going to change the layout at this point.

Matt, do you have an easy solution for this?
Flags: needinfo?(mternoway)
(Assignee)

Comment 23

3 years ago
We could do something like this. It does come across a bit more sparse looking, but still keeps the main info prominent. Let me know what you think of this as an option > http://cl.ly/image/3a202f132R2u
Flags: needinfo?(mternoway)
(Assignee)

Comment 24

3 years ago
Matej and I had a discussion outside of the bug about this and feel this example is the better direction to go with. > http://cl.ly/image/391Y0C2x123a
(In reply to mternoway from comment #24)
> Matej and I had a discussion outside of the bug about this and feel this
> example is the better direction to go with. > http://cl.ly/image/391Y0C2x123a

Thanks, Matt. Looks great.
(Assignee)

Comment 26

3 years ago
Created attachment 8551945 [details]
nologo_privacyDay_january_twitter-timeline.png
(Reporter)

Comment 27

3 years ago
Awesome. Thanks so much!

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.