Closed Bug 1116514 Opened 8 years ago Closed 8 years ago

Pressing enter key in address bar will take you to another URL if that URL is highlighted in the drop-down list

Categories

(Firefox :: Untriaged, defect)

34 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1043584

People

(Reporter: o3031391, Unassigned)

Details

Attachments

(1 file)

1.16 MB, application/x-shockwave-flash
Details
Attached file Bad_ff_url-bar.swf
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141125180439

Steps to reproduce:

Type a partial (beginning letters) of a URL in the address box, and FF will finish putting the URL in the box if it finds one that matches the remaining letters.  Also, FF will  show a drop-down list of recent sites with addresses containing the partial letters you typed.

Now, if you hover the mouse over 1 of those drop-down list items, then it will be selected.  Next, either finish typing the URL yourself or press the End key to accept the URL that was pre-populated by FF (this address should be different than the one hilighted in the drop-down list).  Finally, press the Enter key to go to the URL displated in the address box.


Actual results:

Instead of going to the website for the URL displayed in the address box, FF goes to the website of the hilighted item in the address box drop-down list.


Expected results:

FF should go to the address typed/displayed in the address box, NOT the one highlighted in the address drop-down list.
This is duplication of Bug 1043584.
And fixed in Aurora36.0a2 and later.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043584
You need to log in before you can comment on or make changes to this bug.