If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove the code to handle shutdown-cleanse from the cache service

RESOLVED FIXED in mozilla38

Status

()

Core
Networking: Cache
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

(Blocks: 1 bug)

unspecified
mozilla38
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

shutdown-cleanse has not been a thing for quite a while.
Created attachment 8542631 [details] [diff] [review]
Remove the code to handle shutdown-cleanse from the cache service
Attachment #8542631 - Flags: review?(mcmanus)
Comment on attachment 8542631 [details] [diff] [review]
Remove the code to handle shutdown-cleanse from the cache service

Review of attachment 8542631 [details] [diff] [review]:
-----------------------------------------------------------------

toss to honza
Attachment #8542631 - Flags: review?(mcmanus) → review?(honzab.moz)
Comment on attachment 8542631 [details] [diff] [review]
Remove the code to handle shutdown-cleanse from the cache service

Looks ok for me, but let rather Michal check quickly.
Attachment #8542631 - Flags: review?(honzab.moz) → review?(michal.novotny)
FWIW this is dead code elimination.
Attachment #8542631 - Flags: review?(michal.novotny) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/cb57bc86d90b
Assignee: nobody → ehsan
https://hg.mozilla.org/mozilla-central/rev/cb57bc86d90b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
Duplicate of this bug: 820613
Fwiw, do we want to remove the following last comment too?

http://mxr.mozilla.org/mozilla-central/search?string=shutdown-cleanse&case=on
{{
/profile/notifications.txt
    * line 59 -- NOTE: Long ago there was be a "shutdown-cleanse" version of shutdown which was
}}
Blocks: 791546
You need to log in before you can comment on or make changes to this bug.