Closed Bug 1116594 Opened 5 years ago Closed 5 years ago

Yes button is blank when deleting Hello conversation

Categories

(Hello (Loop) :: Client, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1106906
mozilla37

People

(Reporter: rbillings, Unassigned)

Details

Attachments

(1 file)

Clicking the trash icon for existing conversations displays a no/yes popup, and the yes button is blank.
This is a Hello bug I think, as opposed to part of the tour
Component: Tours → General
Product: Firefox → Loop
QA Contact: anthony.s.hughes
Target Milestone: Firefox 37 → mozilla37
Thanks for reporting this.  I can't repro this.  I suspect this is something unique to your profile or installation.  Is this bug repeatable for you?  Are/were you using Nightly?  Are there any error messages in the browser console when you delete your conversations?   Have you been doing any language localizations (or anything atypical related to languages or customizations) with your browser profile?
Component: General → Client
Flags: needinfo?(rbillings)
Agree this is not a tour bug. Yes, I can repro it, on the Hello tour page and also on random tabs with Hello initiated from the toolbar. I am using Nightly, updated today to 37.0a1 (2014-12-30). No errors in the browser console upon clicking delete icon, or after deleting. No language localizations and definitely not on e10s.

Let me know if you'd like a video snippet or if I can answer any more questions.
Flags: needinfo?(rbillings)
A video snippet would be appreciated. Thanks. Is your profile a new profile (that you created for Hello testing), an existing one that you've had for a while and use for testing, or is it your personal profile? Also, does this bug persist across browser restarts?
Flags: needinfo?(rbillings)
If it helps I can reproduce this using OSX 10.10 Yosemite using the latest Nightly. The bug does not occur on OSX 10.9 using the same Firefox version.
Rebecca-- Are you also using OSX 10.10?
Mark, Mike, Matt, Niko -- Any idea why there would be an OS dependency for this bug?  See Comment 5.  Sounds like this bug is reproducible on the latest OSX (10.10) but not 10.9.  It also seems like any root cause problem for this would be bigger than Hello -- that we'd be seeing other problems in Firefox like this on 10.10.
Flags: needinfo?(standard8)
Flags: needinfo?(nperriault)
Flags: needinfo?(mdeboer)
Flags: needinfo?(MattN+bmo)
Bug 1100401 / 1106906?
Sören -- Thank you for the bug reference!  This really looks like it's a dup of bug 1106906 or Bug 1100401 (which was originally marked as a dup of bug 1106906 and then reopened because it pre-dated the cause of bug 1106906).

Alex/Rebecca -- Just a couple of more questions:

(1) Can you confirm that the "yes" button (even though it is blank) still works on 10.10?  In other words, if you click the button where "yes" should be, is the conversation successfully deleted?

(2) Can you try Aurora (dev edition) and Beta and see if you can repro this bug on those (since I don't have a 10.10 mac)?  

Reading the comments in Bug 1106906, it looks like bug 1106906 (which this may be a dup of) is a regression introduced by the fix to Bug 1072342, which is currently in Aurora (Fx36) and Nightly (Fx37) for 10.10 users, but NOT in Beta (Fx35).  If this is the same bug, I would expect Beta to be unaffected.   There seems to be less known about the regression range for bug 1100401.
Flags: needinfo?(agibson)
Mark, Mike, Matt, Niko -- Feel free to chime in, but it seems like this bug is a dup of a general Firefox issue with Yosemite (either bug 1106906 or bug 1100401).  I don't believe Beta (Fx35) is affected, but I'm waiting to hear back from someone with a Yosemite machine who can verify that for me/us.  If any of you have a Yosemite machine, please try it with Beta and let me know what you find.  FYI: I'm traveling Dec 31 - Jan 3rd; so I'll be laggy on bugmail and email until the 3rd.
Flags: needinfo?(standard8)
Flags: needinfo?(nperriault)
Flags: needinfo?(mdeboer)
Flags: needinfo?(MattN+bmo)
(In reply to Maire Reavy [:mreavy] (Plz needinfo me - PTO until 3rd January) from comment #10)
> I don't believe Beta (Fx35) is affected, but I'm waiting to hear
> back from someone with a Yosemite machine who can verify that for me/us.  If
> any of you have a Yosemite machine, please try it with Beta and let me know
> what you find.

I tested Firefox Beta on Yosemite. Beta is not affected.
This is an existing profile, but it’s only about a month old. 
Yes, the bug persists across browser restarts.
I am also on OSX 10.10 Yosemite.
The YES button does function as expected, and conversations are deleted.
FYI: the Yes button fills in correctly once you run a cursor over it

Repros on: 12/31 nightly, 36.0a2 developer ed. aurora
Does not repro on 12/31 FF beta 35.0

Sounds like a dupe of the above.
Flags: needinfo?(rbillings)
Clearing my needsinfo as Comment 12 also matches what I can reproduce.
Flags: needinfo?(agibson)
Thanks, Sören, Rebecca, and Alex, for all the feedback and info.  I'm going to dup this to Bug 1106906 and then retest once a fix for that lands.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1106906
You need to log in before you can comment on or make changes to this bug.