If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

If i write html with javascript and use meta http-equiv withe charset=Windows-1252, Mozilla do nothing !

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
P3
major
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: bruno, Assigned: harishd)

Tracking

Trunk
mozilla1.4beta
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112009

If I write html code page with javascript and use "meta http-equiv" withe
"charset=Windows-1252", Mozilla do nothing (it freeze) !
If I remove this, all work!

My probleme is that I dowload page with html code with charset, it work evry
where (IE, NS4) but not on Mozilla/NS6 !
To me, it is very important ;-((

an exemple :
function printPageWithCharset(){
  w = top.frames[0].window.document;
  //w.close();
  w.open("text/html","all");
  w.writeln("<html><head>");
  w.writeln('<meta http-equiv="content-type" content="text/html;
charset=Windows-1252">');
  w.writeln("</head><body>");
  for(i=1; i<=100; i++ )
   w.writeln( 'line'+i+'<BR>' );
  w.writeln("</body>\n</html>");
  w.close();	
}

Reproducible: Always
Steps to Reproduce:
1.goto to http://www.lug.com/users/bruno/boguemozilla/index.htm
2. if you click link printPage() it work !
2. but if you click link  printPageWithCharset() it freeze
The 2 links call a javascript where the script printPageWithCharset()
write too the line   w.writeln('<meta http-equiv="content-type"
content="text/html; charset=Windows-1252">');
but if you change Windows-1252 by ISO-8859-1 all work !
the page of scrip is toolbar/htm !

Expected Results:  that link  "printPageWithCharset()" do the same thing that
link   "printPage()" !


the problem is du to the charset !
In fac under W2K only charset ISO-8859-1 work all other charset are bad !
DOM0
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → amar
seeing this on current linux
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Hardware: PC → All

Comment 3

16 years ago
Using Mozilla trunk binaries from today, 2001-11-26-xx, here's what I see:

WinNT, Mac9.1 : The problem is intermittent. When I click on
                "printPageWithCharset()", sometimes nothing happens.
                But if I try again, two/three/four times, it eventually works!                                                                 
                Every click thereafter will then work.

Linux: "printPageWithCharset()" never seems to work, no matter 
        how many times I try it. Note: no errors in the JS Console,
        as to be expected with a bug that is intermittent like this one.
I bet this is due to us re-fetching the content in some cases when we see a
charset  in a meta tag. Over to the HTML parser, Harish, can we do something
about this? Special case the charset handling when parsing from a string?
Assignee: jst → harishd
Keywords: mozilla1.0
(Assignee)

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → mozilla0.9.8
(Assignee)

Comment 5

16 years ago
I think this bug is similar to 95487. Phil, could you please verify? Thanx.

Comment 6

16 years ago
Using Mozilla trunk binaries from today, 2002-01-16-xx, here's what I see:

WinNT, Mac9.1 : The problem is intermittent. When I click on
                "printPageWithCharset()", sometimes nothing happens.
                But if I try again, two/three/four times, it eventually works!                                                                 
                Every click thereafter will then work.

Linux: "printPageWithCharset()" never seems to work, no matter 
        how many times I try it. Note: no errors in the JS Console,
        as to be expected with a bug that is intermittent like this one.


Summary: same behavior as before. It looks like the fix for bug 95487
did not affect this bug -
(Assignee)

Comment 7

16 years ago
Out of time. Mass move to 0.9.9
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 8

16 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2
Target Milestone: mozilla1.2alpha → mozilla1.2beta
(Assignee)

Comment 9

15 years ago
Moving to a realistic milestone
Target Milestone: mozilla1.2beta → mozilla1.3beta
(Assignee)

Updated

15 years ago
Target Milestone: mozilla1.3beta → mozilla1.4beta
(Assignee)

Comment 10

15 years ago
In the recent build ( from yesterday ) I see "content" for aProvider and
"p3p/p3p200201.xsl" for aFile. 
(Assignee)

Comment 11

15 years ago
oops ignore my last comment ( comment #10 ) - wrong bug.

Comment 12

13 years ago
Is this bug still active? I tried several times the PrintPageWithCharset() at
the provided URL and it WORKSFORME every time.
Mozilla 1.7 final release build 20040616 under XP Pro SP1a here.

Comment 13

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040831

That's XP SP2 - WFM.

Comment 14

13 years ago
The testpage at the provided URL also WORKSFORME: Mozilla 1.8a3 build 2004083008
under XP Pro SP2 here.

Resolving as WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.