really could use JSON bookmarks diff-merge tool, SYNC not doing anything

RESOLVED WONTFIX

Status

()

Firefox
Sync
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Jim Michaels, Unassigned)

Tracking

36 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141228004007

Steps to reproduce:

tried Sync across disparate machines and also with ff dev ed and ff.


Actual results:

- no way to diff and merge Bookmarks between bookmarks-disparate machines.
- Sync is doing nothing for me, not even sure what it really does for me except throw dire warnings around about messing things up royally if sync isn't used right. Sync (by implication of the name) didn't sync up my bookmarks between disparate machines. maybe Sync just needs to be fixed. now I have a useless (?) new sync account.


Expected results:

I would like to have a JSON bookmarks diff-MERGE tool. I think I and probably a number of other people with multiple computers could really use that. it at the very least should add entries from 2nd list that are new and give the user the choice to merge to original list or save to a 3rd new list.

Updated

3 years ago
Component: Untriaged → Sync
(Reporter)

Comment 1

3 years ago
could the SYNC problem perhaps be because of https://bugzilla.mozilla.org/show_bug.cgi?id=1046954
(Reporter)

Comment 2

3 years ago
an example of a nice visual format+editor of a diff+merge tool is http://sf.net/projects/winmerge
but since it's JSON, you would have to process the JSON internally and display as something more readable but still editable (albeit through an editing API I should think).
I'm afraid we aren't going to build such a tool given Sync exists.  You seem to be having trouble with Sync, so we should look into resolving that.  https://philikon.wordpress.com/2011/06/13/how-to-file-a-good-sync-bug/ or https://wiki.mozilla.org/CloudServices/Sync/Client_Log_Debugging might be useful.  If you want more immediate help, the #sync IRC channel (see https://wiki.mozilla.org/IRC) would be a good place to get help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

3 years ago
Created attachment 8547900 [details]
error-1420733692457.txt (latest sync log)
(In reply to Jim Michaels from comment #5)
> Created attachment 8547900 [details]
> error-1420733692457.txt (latest sync log)

Thanks for those logs.  Many of the logs imply network errors during a sync, which *should* end up being recovered from, and a couple of the logs look like bookmarks did get sent from the first profile.

Would it be possible to use about:config to set the existing pref "services.sync.log.appender.file.logOnSuccess" to the value |true| and try again a few times?  This *should* cause some "success-***.log" files to appear if a sync did complete successfully.  And while this is a total long shot, at least one user with Sync issues found the problem went away once they reset their router - that might be worth trying too.

Updated

3 years ago
Flags: needinfo?(jmichae3)
(Reporter)

Comment 7

2 years ago
I had a bad NIC. that turns them into a noise generator basically. this is the 2nd-3rd time this has happened in 10 years, different make,model.
Flags: needinfo?(jmichae3)
You need to log in before you can comment on or make changes to this bug.