If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FFOS7715 v2.1][system]In the failed state or manual stop download files , when phone re in network environment, some of the files can be automatically resume downloads, some files can't be automatically download

RESOLVED INVALID

Status

Firefox OS
Gaia::Browser
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: zhaoyang, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141119030200

Steps to reproduce:

In the failed state or manual stop download files , when phone re in network environment, some of the files can be automatically resume downloads, some files can't be automatically download

1.ready in the failed state or manual stop download files,and make sure phone in  no network environment
2.make phone re in network environment
3.some of the files can be automatically resume downloads, some files can't be automatically download


Actual results:

some of the files can be automatically resume downloads, some files can't be automatically download


Expected results:

 in the failed state or manual stop download files can't be automatically download
(Reporter)

Comment 1

3 years ago
Hi  Gregor:

   I know you when I fallow Bug 1077595. please help me to investigate.
    
   Thanks a lot. 

   ps: if you have any problem, please need info for me, i will reply quickly.
status-b2g-v2.1: --- → affected
Flags: needinfo?(anygregor)
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
(Reporter)

Updated

3 years ago
Summary: In the failed state or manual stop download files , when phone re in network environment, some of the files can be automatically resume downloads, some files can't be automatically download → [download]In the failed state or manual stop download files , when phone re in network environment, some of the files can be automatically resume downloads, some files can't be automatically download
Does this work in other browsers? Mobile and desktop?
Flags: needinfo?(anygregor)
Whiteboard: [systemsfe]
(Reporter)

Comment 3

3 years ago
(In reply to Gregor Wagner [:gwagner] from comment #2)
> Does this work in other browsers? Mobile and desktop?

Hi Gregor!

Tt appears in FireFox OS v2.1
I think it doesn‘t matter with browser
Once we stop download,it shouldn‘t begin unless we start it again
I feel it‘s problem of downloadmanager mechanism
(Reporter)

Updated

3 years ago
Summary: [download]In the failed state or manual stop download files , when phone re in network environment, some of the files can be automatically resume downloads, some files can't be automatically download → [FFOS7715 v2.1][system]In the failed state or manual stop download files , when phone re in network environment, some of the files can be automatically resume downloads, some files can't be automatically download
[Blocking Requested - why for this release]:
Putting on triage radar. We only debug if its a blocking issue.
blocking-b2g: --- → 2.1?
Keywords: qawanted
This issue does occur on the Flame 2.2(319mb)(KK)(Full Flash)

The interrupted download did not automatically resume after the phone regained a data connection.

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150106010234
Gaia: b77e0d56d197e0ee02d801a25c784130d888c9db
Gecko: 2a193b7f395c
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
Flags: needinfo?(pbylenga)
Keywords: qawanted
QA Contact: ktucker
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
NI :ktucker to confirm if this is a regression and reproducible on 2.1.
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: qawanted
This issue reproduces on Flame 3.0, 2.2, 2.1 and 2.0

A failed or manually stopped download will automatically start once a WiFi connection is re-established.

Flame 3.0

Environmental Variables:
Device: Flame 3.0(Full Flash)(319mb)(KK)
Build ID: 20150113010202
Gaia: 9946a490a9264b42e65385d703b28fa055ab2d42
Gecko: 3d846527576f
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 38.0a1 (3.0)
Firmware Version: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Flame 2.2

Environmental Variables:
Device: Flame 2.2(Full Flash)(319mb)(KK)
Build ID: 20150113002520
Gaia: 7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko: df130262b09e
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a2 (2.2)
Firmware Version: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Flame 2.1

Environmental Variables:
Device: Flame 2.1(Full Flash)(319mb)(KK)
Build ID: 20150113001255
Gaia: 836e6d74cb8b7016df555f85445893b3ff9aac12
Gecko: 074f79a929d2
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Flame 2.0

Environmental Variables:
Device: Flame 2.0(Full Flash)(319mb)(KK)
Build ID: 20150113000203
Gaia: 31d6c9422cd0a8213df9f96019c9ab7168ec3ab3
Gecko: c6fd5db59e0e
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
status-b2g-v2.0: --- → affected
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
status-b2g-master: --- → affected
:Ktucker, Is there a way to recover the download manually ? Otherwise I feel we should investigate this as if I have downloaded a file 90% and have to start from scratch that would not be nice.
blocking-b2g: 2.1? → 2.1+
(In reply to bhavana bajaj [:bajaj] from comment #8)
> :Ktucker, Is there a way to recover the download manually ? Otherwise I feel
> we should investigate this as if I have downloaded a file 90% and have to
> start from scratch that would not be nice.

This depends on the server capability. We can't do anything if the server doesn't support this. Setting to unblock since this is not a regression.
blocking-b2g: 2.1+ → ---
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)

Updated

3 years ago
Blocks: 1123554
Hi Gregor, then to me this one is not an issue. Should we close it as invalid?

Thanks
Flags: needinfo?(anygregor)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(anygregor)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.