If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FFOS7715 v2.1][system]delete the downloading file in settings/downloads, pull down the utility_tray, the download_notification still exists and is in the downloading state

VERIFIED FIXED in Firefox OS v2.1

Status

Firefox OS
Gaia::System
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: zhaoyang, Assigned: mancas)

Tracking

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.1S fixed, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141119030200

Steps to reproduce:

In WiFi environment, download one file, close WiFi, the phone is in no network environment, download file will be in the downloading state, delete the file in settings/downloads, pull down the utility_tray, the download_notification still exists and is in the downloading state

1.In WiFi environment, download one file
2.close WiFi, the phone is in no network environment, download file will be in the downloading state
3.delete the file in settings/downloads
4.pull down the utility_tray, the download_notification still exists and is in the downloading state


Actual results:

pull down the utility_tray, the download_notification still exists and is in the downloading state


Expected results:

the download_notification will disappear
(Reporter)

Updated

3 years ago
status-b2g-v2.1: --- → affected
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
(Reporter)

Comment 1

3 years ago
Hi kenvin:

   I know you are expected in utility tray and notification, please help me to investigate. 
    thanks a lot. 

   ps: if you have any problem, please need info for me, i will reply quickly.
Flags: needinfo?(kgrandon)
I'm gonna forward this over to Aus who would probably be able to better answer a download notification question than I am.
Flags: needinfo?(kgrandon) → needinfo?(aus)
(Reporter)

Comment 3

3 years ago
(In reply to Kevin Grandon :kgrandon from comment #2)
> I'm gonna forward this over to Aus who would probably be able to better
> answer a download notification question than I am.

Thanks Kevin!
(Reporter)

Comment 4

3 years ago
Hi Aus:

    As of comment 3, please help me. 
    thanks a lot. 

   ps: if you have any problem, please need info for me, i will reply quickly.
(Reporter)

Updated

3 years ago
Component: General → Gaia::Settings
(Reporter)

Updated

3 years ago
Component: Gaia::Settings → Gaia::System

Comment 5

3 years ago
I feel like this is something that I fixed in a later build. Could the reporter retest with latest 2.1?

Thanks!

See bug 1077595 for more info. The fix on 2.1 landed on the 20th.
Flags: needinfo?(aus) → needinfo?(David.Zhao)
(Reporter)

Comment 6

3 years ago
(In reply to Ghislain Aus Lacroix [:aus] from comment #5)
> I feel like this is something that I fixed in a later build. Could the
> reporter retest with latest 2.1?
> 
> Thanks!
> 
> See bug 1077595 for more info. The fix on 2.1 landed on the 20th.

Hi Ghislain,
I reproduce it with latest 2.1
I think there is some differet with bug 1077595
bug 1077595:the file is downloading really
I report the bug is that the wifi and data is off and the file is ‘downloading’,but the ‘downloading‘ is just Performance and the download is stop in fact

Please fallow the steps:
1.In WiFi environment, download one file
2.close WiFi and data, the phone is in no network environment, download file will be in the downloading state
3.delete the file in settings/downloads
4.pull down the utility_tray, the download_notification still exists and is in the downloading state
Flags: needinfo?(David.Zhao) → needinfo?(aus)
(Reporter)

Updated

3 years ago
Summary: [notification]delete the downloading file in settings/downloads, pull down the utility_tray, the download_notification still exists and is in the downloading state → [FFOS7715 v2.1][system]delete the downloading file in settings/downloads, pull down the utility_tray, the download_notification still exists and is in the downloading state
Whiteboard: [systemsfe]
Does this reproduce on current trunk?
Keywords: qawanted
[Blocking Requested - why for this release]:
Putting on triage radar. we are not debugging it if its not a blocking issue.
blocking-b2g: --- → 2.1?
This issue does occur on the Flame 2.2(319mb)(KK)(Full Flash).

After deleting the file from settings/downloads, the file will still be showing in a downloading state in the utility tray.

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150106010234
Gaia: b77e0d56d197e0ee02d801a25c784130d888c9db
Gecko: 2a193b7f395c
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
QA Contact: ktucker
status-b2g-v2.2: --- → affected
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
(Assignee)

Updated

3 years ago
Assignee: nobody → b.mcb
(Assignee)

Comment 10

3 years ago
Created attachment 8545772 [details] [review]
Proposed patch

Hey Alive, could you review this patch? Notice that maybe we need someone from the Settings app to review the iac code in the app.

Thanks!
Attachment #8545772 - Flags: review?(alive)

Comment 11

3 years ago
Comment on attachment 8545772 [details] [review]
Proposed patch

While this does work, I don't like it. It doesn't allow other potential users of the downloads api to observe that the download was cancelled. Instead, we should look for 'finalized' state change of the download and remove it from notifications.

If this doesn't work, then it's an API level bug that should be easy to correct.
Flags: needinfo?(aus)
Attachment #8545772 - Flags: review?(alive) → review-
(Assignee)

Comment 12

3 years ago
Comment on attachment 8545772 [details] [review]
Proposed patch

Aus, I've took into account your comments. Please review this new approach using the download state |finalized|

Thanks
Attachment #8545772 - Flags: review- → review?(aus)

Comment 13

3 years ago
Comment on attachment 8545772 [details] [review]
Proposed patch

lgtm! :)
Attachment #8545772 - Flags: review?(aus) → review+
(Reporter)

Comment 14

3 years ago
(In reply to Manuel Casas Barrado [:mancas] from comment #12)
> Comment on attachment 8545772 [details] [review]
> Proposed patch
> 
> Aus, I've took into account your comments. Please review this new approach
> using the download state |finalized|
> 
> Thanks

Hi Casas,
  Will you fix it on latest 2.1 ?
(Assignee)

Comment 15

3 years ago
I'm working in a patch for version 2.1
(Assignee)

Comment 16

3 years ago
Created attachment 8547378 [details] [review]
Proposed patch for v2.1

The patch is ready, waiting for travis and r+.

Thanks!
Attachment #8547378 - Flags: review?(aus)

Comment 17

3 years ago
Fixed on master (v2.2): https://github.com/mozilla-b2g/gaia/commit/7717e178e1930e92c72697473b624ba1ac9a6524
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 18

3 years ago
Patch looks good for 2.1 as well, so do the tests. You'll need to ask for 2.1 approval though before it can be landed. Once it's been approved, I'll be able to land it. Thanks for the fix!
status-b2g-v2.2: affected → fixed

Comment 19

3 years ago
Comment on attachment 8547378 [details] [review]
Proposed patch for v2.1

lgtm! :)
Attachment #8547378 - Flags: review?(aus) → review+
(Assignee)

Comment 20

3 years ago
Comment on attachment 8547378 [details] [review]
Proposed patch for v2.1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): No regression
[User impact] if declined: If the user delete a file from the settings app, the notification will not be removed, so the notification progress will never be updated
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): Low
[String changes made]: No
Attachment #8547378 - Flags: approval-gaia-v2.1?
Can QA/reporter help verify this fix on 2.2 before we do the branch uplift ? Thanks!
blocking-b2g: 2.1? → 2.1+
Flags: needinfo?(David.Zhao)
Keywords: verifyme
This issue is verified fixed on Flame 2.2.

Result: After deleting the file from Settings > Downloads, the download notification no longer exists on the utility tray.

Environmental Variables:
Device: Flame 2.2 (319mb, full flash)
Build ID: 20150113002520
Gaia: 7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko: df130262b09e
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a2 (2.2)
Firmware Version: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

3 years ago
Attachment #8547378 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
(In reply to Ghislain Aus Lacroix [:aus] from comment #17)
> Fixed on master (v2.2):
> https://github.com/mozilla-b2g/gaia/commit/
> 7717e178e1930e92c72697473b624ba1ac9a6524

Are you sure this made the cutoff for v2.2? Based on the time it was merged and the lack of seeing it in the v2.2 commits on Github, I'm skeptical.
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S4 (23jan)
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #23)
> (In reply to Ghislain Aus Lacroix [:aus] from comment #17)
> > Fixed on master (v2.2):
> > https://github.com/mozilla-b2g/gaia/commit/
> > 7717e178e1930e92c72697473b624ba1ac9a6524
> 
> Are you sure this made the cutoff for v2.2? Based on the time it was merged
> and the lack of seeing it in the v2.2 commits on Github, I'm skeptical.

Hmm, I am curious how QA verfiied this in that case. Yeojin, can you comment ?
Flags: needinfo?(ychung)
More to the point, looking at the files changed by this commit, v2.2 tip definitely doesn't have them.
status-b2g-v2.2: verified → affected
(In reply to bhavana bajaj [:bajaj] from comment #24)
> (In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #23)
> > (In reply to Ghislain Aus Lacroix [:aus] from comment #17)
> > > Fixed on master (v2.2):
> > > https://github.com/mozilla-b2g/gaia/commit/
> > > 7717e178e1930e92c72697473b624ba1ac9a6524
> > 
> > Are you sure this made the cutoff for v2.2? Based on the time it was merged
> > and the lack of seeing it in the v2.2 commits on Github, I'm skeptical.
> 
> Hmm, I am curious how QA verfiied this in that case. Yeojin, can you comment
> ?

I was unable to reproduce the bug on today's nightly Flame 2.2. However, I DID reproduce this bug on yesterday's nightly Flame 2.2:

Result: The notification tray still displays the downloading after the file is deleted from Settings > Downloads. 

Environmental Variables:
Device: Flame 2.2
BuildID: 20150112010228
Gaia: f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko: bb8d6034f5f2
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(ychung)
(Reporter)

Comment 27

3 years ago
Hi,

sorry,I'm late.

I verify this on 2.1, looks good.

I have no 2.2 code, so ...
Flags: needinfo?(David.Zhao)
v2.1: https://github.com/mozilla-b2g/gaia/commit/d60af2eac1347424c0cada1093c5bcafa24043d9

I've verified again that the patch that landed on master cherry-picks cleanly to the v2.2 branch. I'm tempted to just push it and be done with it, but will wait for an official approval first :)
status-b2g-v2.1: affected → fixed
Flags: needinfo?(b.mcb)
Got IRC a+ to push this to v2.2.
https://github.com/mozilla-b2g/gaia/commit/affbd8244ca5d2297aeaaa12355196108e7c4800
status-b2g-v2.2: affected → fixed

Comment 30

3 years ago
This issue verified successfull on Flame 2.1&2.2:
Flame 2.2 Build:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ce27f2692382
Build-ID        20150115002505
Version         37.0a2
Flame 2.1 Build:
8d4846d7bec777046dc5e3d2b8005adb1370f1f7
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8eb9bc3a945a
Build-ID        20150115001207
Version         34.0
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified

Updated

3 years ago
Status: VERIFIED → RESOLVED
Last Resolved: 3 years ago3 years ago

Comment 31

3 years ago
Created attachment 8550049 [details]
VIDEO0248_Compress.MP4

This issue verified successfull on Flame 2.1&2.2: refer to video VIDEO0248_Compress.MP4

Comment 32

3 years ago
v2.1s : https://github.com/mozilla-b2g/gaia/commit/d60af2eac1347424c0cada1093c5bcafa24043d9
status-b2g-v2.1S: --- → fixed
This issue is verified fixed on Flame Master.

Result: After deleting the file from Settings > Downloads, the download notification no longer exists on the utility tray.

Device: Flame Master (319mb, full flash)
BuildID: 20150123010227
Gaia: cba2f0bf49b882e0044c3cc583de8fcf83d2ffa4
Gecko: 494632b9afed
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Assignee)

Comment 34

3 years ago
Clearing my ni
Flags: needinfo?(b.mcb)
You need to log in before you can comment on or make changes to this bug.