[Stingray] Improve key navigation feature

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: lchang, Assigned: lchang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ft:conndevices])

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
We fail to navigate the elements which is much bigger than the current focused one under certain circumstances.
(Assignee)

Comment 1

3 years ago
Created attachment 8542861 [details]
Demo

Put this file into "gaia/tv_apps/tv_shared/js/", run it in the browser and you will see the problem.
(Assignee)

Comment 2

3 years ago
Created attachment 8542864 [details] [review]
Pull request to master

Hi Tzu-Lin and John,

Could you take a look at my patch? Thanks.
Assignee: nobody → lchang
Status: NEW → ASSIGNED
Attachment #8542864 - Flags: review?(tzhuang)
Attachment #8542864 - Flags: review?(im)
(Assignee)

Comment 3

3 years ago
The current behavior of smart-home will become a little bit strange because the size of "div#card-list-frame" is set to be fullscreen currently. Navigating to a fullscreen element should be unexpected. We may need to fix that in advance.
(Assignee)

Comment 4

3 years ago
After this patch landed, we may reconsider if the patch in Bug 1114452 is still necessary or not.
See Also: → bug 1114452
(Assignee)

Comment 5

3 years ago
Comment on attachment 8542864 [details] [review]
Pull request to master

Hi Rex,

Per comment 3, you're familiar with the interaction among SpatialNavigator and Smart-Home. Could you please help on this? Thanks.
Attachment #8542864 - Flags: review?(tzhuang) → review?(rexboy)
Comment on attachment 8542864 [details] [review]
Pull request to master

Looks good to me...

When we press "right" at the top-right corner, the focus will goes to the center-right element. According to the algorithm, it is correct. But is this what UX wants? IMO, if the patch of bug 1114452 also fixed it, we may need it.
Attachment #8542864 - Flags: review?(im) → review+
(Assignee)

Comment 7

3 years ago
(In reply to John Hu [:johnhu][:johu][:醬糊小弟] (PTO from 12/27 ~ 1/4) from comment #6)
> When we press "right" at the top-right corner, the focus will goes to the
> center-right element. According to the algorithm, it is correct.

Actually, this behavior isn't correct. It's caused by what I mentioned at comment 3.
This patch looks good to me, but after landing we need to fix two regressions that based on
behavior of original spatial navigation:
1. (The one mentioned at comment. 3) In home-app, Pressing right key at search button
   shouldn't move focus to card list.
2. In app-deck, pressing up at second/third row of apps shouldn't move focus to the top
   scrollable.

For the first one it's just a css issue; the second one we need to adjust some structure
of home-app. So I'll hold my r+ until we can confirm those issue above are solved.
Comment on attachment 8542864 [details] [review]
Pull request to master

r=me but I would suggest landing together it with bug 1120381 and bug 1118569 which contain fix to the new behavior.
Attachment #8542864 - Flags: review?(rexboy) → review+

Updated

3 years ago
Whiteboard: [ft:conndevices]
https://github.com/mozilla-b2g/gaia/commit/6b81efbe70a9c5b1c01f40131f6bb72e08925551
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.