[Bluetooth][FFOS7715 v2.1] When playing music calls, phone ring sounds and music from the phone side to play

RESOLVED DUPLICATE of bug 1180618

Status

Firefox OS
Bluetooth
--
major
RESOLVED DUPLICATE of bug 1180618
3 years ago
2 years ago

People

(Reporter: ffos_st, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-master affected)

Details

(Whiteboard: sprd388684)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Description:
When playing music calls, phone ring sounds and music from the phone side to play.

Device:SPRD 7715ea
Build Identifier: 20141231170630

Steps to Reproduce:
1)Bluetooth headset is connected to play music.
2)Phone calls, hang up.

Actual Result:
Music sounds and ringtones from mobile phones will end play, enter the settings view, disconnect Media Audio headphone connection.

Expected Result:
Music will sound and the phone ringing from the headset end play, the headset is connected properly.

Repro frequency:3/5,60%
(Reporter)

Updated

3 years ago
Whiteboard: sprd388684
(Reporter)

Updated

3 years ago
Summary: [FFOS7715 v2.1] When playing music calls, phone ring sounds and music from the phone side to play → [Bluetooth][FFOS7715 v2.1] When playing music calls, phone ring sounds and music from the phone side to play
Hi ffos_st

Could you help to confirm if you can reproduce this issue on Flame 2.1 as well?

Thanks
Flags: needinfo?(ffos_st)
(Reporter)

Comment 2

3 years ago
I can reproduce this issue on Flame 2.1
Flags: needinfo?(ffos_st)

Updated

3 years ago
Blocks: 1123554

Comment 3

2 years ago
qawanted to confirm whether this bug remains on Aries/Flame with the latest m-c.
Keywords: qawanted
Hi Ben,

    This bug can be repro on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0. But it has different actual results compared with comment 0, as below:

Actual results: 
When playing music by bluetooth headset, making a call to test device, it is ring both with ringtone sound and music sound from the speaker. When you end the call, music will continue to play from bluetooth headset. The bluetooth headset is always connected.

See attachments: Flame_v2.5.3gp and logcat_2016.txt
Reproduce rate: 6/6


Device: Flame KK 2.5 (Affected)
Build ID               20150805150207
Gaia Revision          581de383687dc441a878d2c91a0167c6ec688fef
Gaia Date              2015-08-05 01:48:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b12a261ee32e
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150805.195702
Firmware Date          Wed Aug  5 19:57:12 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Affected)
Build ID               20150804223818
Gaia Revision          c5425d9f1f5184731a59ed4bc99295acbde30390
Gaia Date              2015-08-04 16:09:19
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f3b757156f69
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150804.220057
Firmware Date          Tue Aug  4 22:01:05 UTC 2015
Bootloader             s1
status-b2g-master: --- → affected
Flags: needinfo?(btian)
Keywords: qawanted
Created attachment 8644297 [details]
Flame_v2.5.3gp
Created attachment 8644298 [details]
logcat_2016.txt
QA Whiteboard: [MGSEI-Triage+]

Comment 7

2 years ago
ni? Audio dev Blake for desired behavior.

Blake, is comment 4 behavior desired? If so we can resolve this bug as WONTFIX since it doesn't occur on the latest m-c.
Flags: needinfo?(btian) → needinfo?(bwu)
(In reply to Shally Li from comment #4)
> Hi Ben,
> 
>     This bug can be repro on the latest build of Flame KK 2.5 and Aires KK
> 2.5 by the STR in comment 0. But it has different actual results compared
> with comment 0, as below:
> 
> Actual results: 
> When playing music by bluetooth headset, making a call to test device, it is
> ring both with ringtone sound and music sound from the speaker. When you end
> the call, music will continue to play from bluetooth headset. The bluetooth
> headset is always connected.
Alastor, 
Could you help check this behavior?
Thanks!
Flags: needinfo?(bwu) → needinfo?(alwu)
It's normal that the ringtone was playback from both speaker and bluetooth headset. 
However, the music should be paused when the ringtone started, and this problem would be fixed in the bug1180618.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(alwu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1180618
You need to log in before you can comment on or make changes to this bug.