Closed Bug 1116728 Opened 7 years ago Closed 7 years ago

[Flame][Email]When sending email to several recipients whose addresses are separated by semicolon, the email can’t be sent successfully.

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S4 (23jan)
Tracking Status
b2g-v2.1 --- affected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: wangxin, Assigned: asuth)

References

Details

Attachments

(5 files)

Attached video Bug video: 0305.MP4
[1.Description]:
[Flame][v2.1&v2.2][Email]When we send email to several recipients whose email addresses are separated by semicolon, the email can’t be sent successfully.
See video: "0305.MP4".
See log: "logcat_0305.txt".
Found Time: 03:05

[2.Testing Steps]: 
1. Launch "Email".
2. Compose a new mail.
3. Input email address to recipients.
4. Input ";" to separate recipients, and then input another email address.
5. Send the email.

[3.Expected Result]: 
5. The Email should  be sent successfully.

[4.Actual Result]: 
5. The email can’t be sent successfully.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ea426e47bfc4
Build-ID        20141230001256
Version         34.0

Flame 2.2 build:
Gaia-Rev        322ef5116a5827a30c9a3cd9b842449a9c66a5b3
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/67872ce17918
Build-ID        20141230010205
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5
TCID: FreeTest
Hi James, could you help with this, thanks.
Flags: needinfo?(jrburke)
It appears that this is a regression from the email.js upgrades; specifically, addressparser is not interpreting ';' as a delimiter unless a group was used, but its predecessor probably was.  Preparing a test and fix for upstream.
Assignee: nobody → bugmail
Status: NEW → ASSIGNED
Flags: needinfo?(jrburke)
I tested this briefly on v2.0 and the problem reproduces there.  So I'm now thinking this was not an email.js-upgrade-related regression but instead probably something that happened when we moved to using addressparser/friends in the front-end directly instead of our naive manual process.
QA Whiteboard: [COM=Gaia::Email]
Attached file GELAM pull request
r=andris9 (upstream, treating as deferred review)
Attachment #8552149 - Flags: review+
It's not clear there's particularly any priority to this fix, so just leaving it on trunk.  (This was mainly something I wanted fixed in upstream for future benefit.)  If anyone wants it on v2.2, feel free to request approval.  It is low risk.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
This issue has been verified successfully on Flame3.0

Flame3.0 build:
Build ID               20150216010344
Gaia Revision          f0b93e0668ef9565bd6f050b15b4f794d59feb65
Gaia Date              2015-02-13 13:13:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e0cb32a0b1aa
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150216.050451
Firmware Date          Mon Feb 16 05:05:02 EST 2015
Bootloader             L1TC000118D0
Duplicate of this bug: 1149121
Hi Andrew,
Please uplift this to V2.2 as well. Thanks.
Flags: needinfo?(bugmail)
Comment on attachment 8552190 [details] [review]
landed gaia pull request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Not a regression.
[User impact] if declined: Semicolons don't work as delimiters.
[Testing completed]: Upstream tests were added, and this has baked on trunk for over 2 months.
[Risk to taking this patch]: Very low risk.
[String changes made]: No string changes.

This request is motivated based on the filing of duplicate bug 1149121.
Flags: needinfo?(bugmail)
Attachment #8552190 - Flags: approval-gaia-v2.2?
Attachment #8552190 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been verified successfully on Flame 2.2,
STR as comment0.
Repro rate: 0/10

Flame 2.2 build(Pass): 
Build ID               20150406002503
Gaia Revision          a6351e1197d54f8624523c2db9ba1418f2aa046f
Gaia Date              2015-04-03 22:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c3335a5d3063
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150406.040047
Firmware Date          Mon Apr  6 04:00:58 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.