back button does not go back to previous spot

RESOLVED DUPLICATE of bug 105395

Status

RESOLVED DUPLICATE of bug 105395
17 years ago
14 years ago

People

(Reporter: swv3752, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112007

If a link is clicked in the middle of the page, and the back button is pressed,
the browser goes back to the beginning if the previous page and not to the point
the browser window was at.  Previous milestone releases did not exhibit this
behavior.  An example is that when a link is selected in the middle of an
article at http://slashdot.org , Mozilla goes back to the begining of the
article, when it should go back to the middle of the page where the link was
originally selected.

Reproducible: Always
Steps to Reproduce:
1.goto http://slashdot.org
2. Select any link that is halfway down the page or more, on either the main
site or a subsection of slashdot
3. press the back button


Actual Results:  rather than going back to the original location on the page
where the link was selected, it goes back to the top of the original page

Expected Results:  It should have gone back to the original location on the page
where the link was selected.

This build of mozilla was built from src.rpm on MDK 8.1.  I believe this was
reproduced on the win32 version, but I can not verify at this time.  Prior
builds did not experience this wrong behavior, and other websites do work properly.

Comment 1

17 years ago
For some reason this problem seems to occur on slashdot.org, but not on
bugzilla.mozilla.org.

Is this a dupe of bug 92820?
(Reporter)

Comment 2

17 years ago
It is different from bug #92820.  In that bug it is reproduced only when the
page has not finished loading.  In this one, it occurs after the page has
finished loading.  It seems something peculiar to Slashdot as I am unable to
reproduce on other slash sites.  Sorry, it can be reproduced from
http://slashcode.com ,so it must be with newer versions of slash.

(Assignee)

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 105395 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.