Thunderbird authorization for BOX fails as Filelink storage location for sharing large files "sent" in email.

UNCONFIRMED
Unassigned

Status

Thunderbird
FileLink
UNCONFIRMED
3 years ago
8 months ago

People

(Reporter: James Jenkins, Unassigned)

Tracking

31 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

1) Under tools\options\attachments under the outgoing tab, Add BOX.
2) For Popup selected BOX and clicked on Set Up Account for existing account.
3) Got another Popup for log-in information for BOX
3) Entered correct info for email and password for existing BOX account (previously can log-in independently into BOX with this info outside of Thunderbird).
4) Clicked on Authorize.
5) Another popup appeared and clicked on "Grant Access to Box"







Actual results:

Received the following message:


There seems to be a problem with this app.

Don't worry, your files are perfectly safe. Get in touch with Box support to get assistance with this app. We're here to help.
Error: invalid_client
Show Error Details

scope=root_readwrite
folder_id=
response_type=code
redirect_uri=http://localhost
state=
client_id=exs8m0agj1fa5728lxvn288ymz01dnzn


Expected results:

Filelink should have attached to BOX and "BOX" should appeared in the under the tools\options\attachments window under the outgoing tab.

Updated

3 years ago
Duplicate of this bug: 1116818

Comment 2

3 years ago
If I add "box.com" "Allow" under Options > Privacy > Web Content cookies Exceptions, then box.com file link works for me again and allows adding box to Filelink. TB 31.7.0

Comment 3

3 years ago
TB 38.2.0, W7 (64) SP1. Error seams to persist.
Cookies are allowed for "box.com", "box.net", "boxcdn.net", "boxcloud.com". Unfortunately I still receive the above cited error message complaining about "invalid_client", but for "client_id=exs8m0agj1fa5728lxvn288ymz01dnzn". 
Filelink is not attached to BOX.

Comment 4

3 years ago
TB 38.2.0 
Yes, stopped working for me. I tried deleting and re-adding the service: I no longer get the error message, though. It just waits forever after I click "grant authorization", with a spinning disc at "Checking authorization...". If I cancel while it's spinning, it adds a blank-named account to the list on next restart of TB. This WILL accept authorizing, but stays blank-named. However, it doesn't work for uploading files (spins forever even for small files). The cookies settings seem to make no difference to this.

Updated

2 years ago
Component: Untriaged → FileLink

Comment 5

2 years ago
(In reply to James Jenkins from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101
> Firefox/34.0
> Build ID: 20141126041045
> 
> Steps to reproduce:
> 
> 1) Under tools\options\attachments under the outgoing tab, Add BOX.
> 2) For Popup selected BOX and clicked on Set Up Account for existing account.
> 3) Got another Popup for log-in information for BOX
> 3) Entered correct info for email and password for existing BOX account
> (previously can log-in independently into BOX with this info outside of
> Thunderbird).
> 4) Clicked on Authorize.
> 5) Another popup appeared and clicked on "Grant Access to Box"
> 
> 
> 
> 
> 
> 
> 
> Actual results:
> 
> Received the following message:
> 
> 
> There seems to be a problem with this app.
> 
> Don't worry, your files are perfectly safe. Get in touch with Box support to
> get assistance with this app. We're here to help.
> Error: invalid_client
> Show Error Details

duplicate of bug 1045845?
Flags: needinfo?(rsx11m.pub)

Comment 6

2 years ago
I'm not sure, bug 1045845 mentions a different response "Unable to upload <filename> to Box."
Also, it mentions the attempt of a folder being created, which apparently causes the failure.
Neither of those is listed here as a symptom.
Flags: needinfo?(rsx11m.pub)
You need to log in before you can comment on or make changes to this bug.