If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Removing search terms blanks out results list in address book quick search and contacts side bar search

RESOLVED FIXED in Thunderbird 37.0

Status

MailNews Core
Address Book
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Thomas D., Assigned: sshagarwal)

Tracking

({regression})

unspecified
Thunderbird 37.0
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR

1 in AB quicksearch or contacts side bar, of an AB having contacts "John Doe" and "Jane Doe", search for "John"
2 Remove search terms

Actual result
after 1), correctly showing matching contacts ("John Doe")
after 2), wrongly showing no results at all (blank results pane)

Expected result
After clearing search filter terms, all contacts of respective AB must be shown immediately("John Doe" and "Jane Doe")

For all practical UX purposes, this breaks the main AB quick search and contacts side bar entirely because we can't expect users to click back and forth between ABs each time after clearing search terms -> critical

I think this is pretty new -> regression.
I'm quite sure this was still working some weeks ago, or even days.
Seen on 37.0a1 (2014-12-30)/ WinXP.
(Reporter)

Updated

3 years ago
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 1

3 years ago
If anyone else sees this, pls confirm
(Assignee)

Comment 2

3 years ago
Created attachment 8543153 [details] [diff] [review]
Patch v1

Even if there are no search terms (blank search box),
the queryURI is being formed and hence, SetAbView isn't
able to display all the cards from the selected AB.

Thanks.
Assignee: nobody → syshagarwal
Status: NEW → ASSIGNED
Attachment #8543153 - Flags: review?(mkmelin+mozilla)
(Assignee)

Updated

3 years ago
Keywords: regressionwindow-wanted

Comment 3

3 years ago
Comment on attachment 8543153 [details] [diff] [review]
Patch v1

Review of attachment 8543153 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, thx Suyash! r=mkmelin
Attachment #8543153 - Flags: review?(mkmelin+mozilla) → review+

Updated

3 years ago
Severity: critical → normal
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 4

3 years ago
Thanks.
Keywords: checkin-needed
(Reporter)

Comment 5

3 years ago
I believe this bug should have a test in the test suite, it should never have occured in the first place.
http://hg.mozilla.org/comm-central/rev/2944600ee1ef
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 37.0
Wrong commit above.

http://hg.mozilla.org/comm-central/rev/0da65c550324
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.