system/test/unit/fxa_test/screens/fxam_coppa_test.js are failing after new year

RESOLVED FIXED in 2.2 S3 (9jan)

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: ferjm, Assigned: ferjm)

Tracking

unspecified
2.2 S3 (9jan)
x86
macOS

Firefox Tracking Flags

(b2g-v1.4 fixed, b2g-v2.0 fixed, b2g-v2.0M fixed, b2g-v2.1 fixed, b2g-v2.1S fixed, b2g-v2.2 fixed)

Details

Attachments

(1 attachment)

No description provided.
from irc, or just fix https://github.com/mozilla-b2g/gaia/blob/master/apps/system/fxa/elements/fxa-coppa.html and file a bug to create those options from script rather than hardcode them, that'd work too
I'm on a plane which is about to land and need to get off, so I just pushed a quick fix here which might fix this: https://github.com/mozilla-b2g/gaia/commit/698e6e8a098cc060b26cd6f25171633c4c7e739d

I'll follow-up on this later and try to get a proper fix in.
Keywords: leave-open
Sorry I filed this and I had to run. Thanks for the quick fix Kevin! I can do the patch for the dynamic population of the select.
Assignee: nobody → ferjmoreno
Comment on attachment 8543181 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27093

I left a few comments on github. Could you address then re-flag me for review? Thanks!
Attachment #8543181 - Flags: review?(kgrandon)
Comment on attachment 8543181 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27093

Thanks for the feedback, Kevin.
Attachment #8543181 - Flags: review?(kgrandon)
Comment on attachment 8543181 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27093

Looks good to me. Thanks!
Attachment #8543181 - Flags: review?(kgrandon) → review+
In master: https://github.com/mozilla-b2g/gaia/commit/0a7232d6fa17b4af534c50dbe5dbd1a40e625119
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8543181 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27093

This is causing oranges in TBPL for 1.4, 2.0 and 2.1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Firefox Accounts
[User impact] if declined: None. Dev impact only. The tests will be orange in TBPL.
[Testing completed]: Manual tests and existing unit test runs.
[Risk to taking this patch] (and alternatives if risky): Low risk.
[String changes made]: "fxa-age-1990-earlier" changed to "fxa-age-earlier"
Attachment #8543181 - Flags: approval-gaia-v2.1?
Attachment #8543181 - Flags: approval-gaia-v2.0?
Attachment #8543181 - Flags: approval-gaia-v1.4?
Fabrice, IIRC, Bhavana is on PTO. This is currently a permafail on all B2G release branches. Can you please take a look at the approval request instead? :)
Flags: needinfo?(fabrice)
Flags: needinfo?(fabrice)
Attachment #8543181 - Flags: approval-gaia-v2.1?
Attachment #8543181 - Flags: approval-gaia-v2.1+
Attachment #8543181 - Flags: approval-gaia-v2.0?
Attachment #8543181 - Flags: approval-gaia-v2.0+
Attachment #8543181 - Flags: approval-gaia-v1.4?
Attachment #8543181 - Flags: approval-gaia-v1.4+
v2.1: https://github.com/mozilla-b2g/gaia/commit/78d6cfa477cd5038023b15dfa29a452b6f035c87
v2.0: https://github.com/mozilla-b2g/gaia/commit/3afef63b0389b066f2bc1cc05944ffe1633caec9

This needs rebasing for v1.4. Or maybe it's better to just disable the test there and get on with life.
Flags: needinfo?(ferjmoreno)
Keywords: leave-open
Target Milestone: --- → 2.2 S3 (9jan)
v2.1 is now passing, but v2.0 is still failing? They literally got the exact same patch :(
Just going to disable the test for now to get things green. Fernando - feel free to follow-up and investigate if necessary.

v1.4: https://github.com/mozilla-b2g/gaia/commit/04265f42139a7a5c611c45e4869582642927e835
v2.0: https://github.com/mozilla-b2g/gaia/commit/9ee55ed14cde0ad4290fab513eb04a9bb4ce06f8
Flags: needinfo?(ferjmoreno)
I also had to back it out from 2.0 as it was breaking the FxA flow, not sure why.

v2.0: https://github.com/mozilla-b2g/gaia/commit/f76014fd2c7528493b90d759c68ec3070233d094

Disabling the test on 1.4 and 2.0 works for me.
So why are we breaking string freeze all over the place?
(In reply to Axel Hecht [:Pike] from comment #48)
> So why are we breaking string freeze all over the place?

Flagging Fabrice and Bhavana for input here.
Flags: needinfo?(fabrice)
Flags: needinfo?(bbajaj)
After speaking with Axel and Fabrice I've backout this patch from 2.1 disabling the tests as well, so no string freeze will be broken.

v2.1: https://github.com/mozilla-b2g/gaia/commit/2e00a7d14397b74c1e46828faf4625055dbf9689#diff-1b14b110e7cc64caea13b1bbf0afbdd3R125
Flags: needinfo?(fabrice)
Flags: needinfo?(bbajaj)
You need to log in before you can comment on or make changes to this bug.