Reinstate Commit Access (Level 1) for Shihua Zheng

VERIFIED FIXED

Status

mozilla.org
Repository Account Requests
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Shihua Zheng, Assigned: ashish)

Tracking

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2251.0 Safari/537.36



Actual results:

I got my try permission on bug 1009906. Recently, I find myself unable to commit after my corp ldap (szheng@mozilla.com) got deleted.


Expected results:

Could any op add this email (seward.zheng@gmail.com) to ldap and grant HG and L1? The public key is the same as bug 1009906 and the form was processed before. Thx a lot!

Comment 1

3 years ago
Need to get this bug in the right hands. Stand by.
Kyle: do you have independent confirmation that this account is a known email for szheng? This was filed from a different BMO account than the original request (bug 1009906).

Marcia: do you still handle these?
Flags: needinfo?(mozillamarcia.knous)
Flags: needinfo?(khuey)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Daniel Veditz [:dveditz] from comment #2)
> Kyle: do you have independent confirmation that this account is a known
> email for szheng? This was filed from a different BMO account than the
> original request (bug 1009906).
> 
> Marcia: do you still handle these?

I still do, but the workflow is about to change - I am waiting to hear back from fox2mike regarding this. Right now the kick back message that you get about where to file bugs is confusing.
Flags: needinfo?(mozillamarcia.knous)
I have corresponded with Shihua at that email address in the past.  It would be nice if we could merge the bugzilla accounts.
Flags: needinfo?(khuey)
Moving this back to Repo requests - Ashlee can we just change his email from szheng@mozilla.com to seward.zheng@gmail.com?
Assignee: nobody → mozillamarcia.knous
Component: Operations Security (OpSec): General → Repository Account Requests
Flags: needinfo?(seward.zheng)
Flags: needinfo?(seward.zheng)
(In reply to Marcia Knous [:marcia - use needinfo] from comment #5)
> Moving this back to Repo requests - Ashlee can we just change his email from
> szheng@mozilla.com to seward.zheng@gmail.com?

and if we have to make this a community LDAP, then so be it since he is no longer an intern.
Assignee: mozillamarcia.knous → achavez
Hi Ashlee, what's the status of this? I'd love to get Shihua unblocked ASAP. Thanks!
Flags: needinfo?(achavez)
(Assignee)

Updated

3 years ago
Assignee: achavez → ashish
(Assignee)

Comment 8

3 years ago
I've moved the LDAP and SSH bits from szheng@mozilla.com to a new community LDAP account seward.zheng@gmail.com.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(achavez)
Resolution: --- → FIXED
Thanks! Shihua, can you please verify that your access is restored?
Flags: needinfo?(seward.zheng)
(Reporter)

Comment 10

3 years ago
Ashish, is my public key ported as well? I still cannot push to try.
Flags: needinfo?(seward.zheng) → needinfo?(ashish)
(Assignee)

Comment 11

3 years ago
Yes - seward.zheng@gmail.com with fingerprint

> 1024 1a:95:e1:91:34:df:a8:77:7a:f8:7d:73:fa:3f:71:5d  sewardj@nehemiah (DSA)
Flags: needinfo?(ashish)
(Reporter)

Comment 12

3 years ago
(In reply to Ashish Vijayaram [:ashish] from comment #11)
> Yes - seward.zheng@gmail.com with fingerprint
> 
> > 1024 1a:95:e1:91:34:df:a8:77:7a:f8:7d:73:fa:3f:71:5d  sewardj@nehemiah (DSA)

That might be the problem. I actually do not own this keypair. This machine name is not mine either. Could you setup my key as the attachment on bug 1009906?

Thanks!
Flags: needinfo?(ashish)
FWIW, that's probably Julian Seward's key.  Not sure how it got involved here.
(Assignee)

Comment 14

3 years ago
Hmm odd. I blame myself for the confusion. Sorry. I've updated the LDAP for seward.zheng@gmail.com with the correct SSH key. Should propagate in ~40 mins.

2048 68:6b:a0:aa:49:3f:5a:7a:79:6f:ea:6a:08:51:41:f6  powerivq@ubuntu (RSA)
Flags: needinfo?(ashish)
Shihua, can you verify that your account works now?
Flags: needinfo?(seward.zheng)
(Reporter)

Comment 16

3 years ago
(In reply to ben turner [:bent] (use the needinfo? flag!) from comment #15)
> Shihua, can you verify that your account works now?

Works now.
Flags: needinfo?(seward.zheng)
\o/
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.