If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

After wakeup from standby and changing internet connection from mobile data to WiFi Firefox cannot get a connection to internet

RESOLVED DUPLICATE of bug 991923

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 991923
3 years ago
a year ago

People

(Reporter: Herbert, Unassigned, NeedInfo)

Tracking

34 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

1. My HTC one (M7) has been im standby for some time
2. Wake my phone up
3. Wait until network interface changed from mobile data (LTE/UMTS/EDGE) to Wifi
4. Use Firefox



Actual results:

Firefox seems to stuck with an old handle of the network interface and cannot get connection to the network after switching to Wifi. Using the built-in Android browser or other apps that need internet connection works fine.



Expected results:

Firefox should have/fetch a valid network handle after switch from mobile data to Wifi (and vice versa) so that Firefox can continue to access internet.
(Reporter)

Updated

3 years ago
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Can you try Nightly (https://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-api-11/fennec-37.0a1.multi.android-arm.apk)? We recently may have fixed this. You can also try Firefox Beta on Google Play which contains a fix from bug 1024614.
Flags: needinfo?(herbert_reichl)
(Reporter)

Comment 2

3 years ago
Thank's for the hint. I've tried Firefox Beta but it also fails. Nightly I'm currently testing, first impression is that the problem is fixed, but it's too early to decide. I'll add another comment, when I'm sure.
Which bug might have fixed this on trunk (aurora?) again?
Flags: needinfo?(snorp)
Bug 991923 fixed this, so Aurora should be good to go. We decided it would just ride the trains, I think?
Flags: needinfo?(snorp)
We'll evaluate in that bug. Thanks for the report Herbert.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 991923
You need to log in before you can comment on or make changes to this bug.