[OpenC-2.0] White screen and device hangs after trying to pick up an incoming call

RESOLVED INVALID

Status

Firefox OS
General
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Mossroy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
I faced this issue twice, on 2 different ZTE OpenC FR devices.
Both have been rooted with the ZTE tool, and installed with the 2.0 community build, dated 20141123 (http://builds.firefoxos.mozfr.org/doc/fr/devices/zte-open-c-fr#telechargement)

What happened :
- a phone call is incoming
- the device rings
- the user tries to answer the call
- the devices hangs with a completely empty white screen
- the phone does not respond to anything (screen or buttons)
- only one solution : remove the battery and reboot

The white screen looks like the one in this video : http://youtu.be/V8-r6hRXkH4 (but it did not happen while browsing : it was when picking up an incoming call)
(Reporter)

Comment 1

3 years ago
This issue is hard to reproduce : it happens very rarely.

Could it be a bug in the low-level layers of the phone, that has been fixed in the B03 build of ZTE?
See the changelog in http://www.ztefrance.com/assistance/#faq (choose "Open C" -> "Questions fréquentes" -> "Version logicielle") :

La version FFOS_FR_ZTE_OPENCV1.0.0B03 (disponible mi-Octobre 2014) apporte les améliorations suivantes :
1) Correction d'un bug provoquant des redémarrages intempestifs lors des appels
(...)

(translation : the B03 version fixes a bug that reboots the device on an incoming call)

If I understood correctly, the community builds use the low-level layers (kernel, gonk) from the root tool of ZTE (which is version B02, not B03)
(Reporter)

Comment 2

3 years ago
It might be a duplicate of bug 1017604.

I did not face it for a long time, but maybe I've just been lucky?
(Reporter)

Comment 3

3 years ago
This issue seems to be specific to the ZTE Open C device.
It seems to be fixed in the official 1.3 B03 version of ZTE, but not in the community builds (because they are based on a 1.3 B02 rooted version).

I close this as invalid in this bugtracker.
The issue is tracked in https://bugzilla.frenchmozilla.org/show_bug.cgi?id=608
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.